Forum Xamarin.iOS

Xcode 11 and upload IPA file without Application Loader

yuraxyurax RUMember ✭✭

How to upload IPA file (Xamarin.iOS app) to AppStore without Application Loader, that is removed from Xcode 11? I'm using Visual Studio 2019 for Mac.
Is it possible download Application Loader utility manually?


  • yuraxyurax RUMember ✭✭

    Thanks! It works for me. I'm successfully uploaded ipa file yesterday.

  • taitotaito USMember ✭✭

    Does not work for me: Error Domain=ITunesSoftwareServiceErrorDomain Code=-22014 \"We are unable to create an authentication session.\" UserInfo={NSLocalizedDescription=We are unable to create an authentication session., NSLocalizedFailureReason=Unable to validate your application.}"

    Why was it removed? That is a step back... Enter the password in plain text in the console, 2-factor authorization...

  • yuraxyurax RUMember ✭✭

    taito, YOUR_ITMC_PASSWORD is NOT your apple id password, but your application password, that you generated on page

  • YuliaMYuliaM Member

    Guys, thanks a lot! It took me a couple of minutes with terminal, compared to almost an hour with application loader

  • justice501justice501 Member
    edited September 2019
    • Archive your app on Visual Studio.
    • Open Xcode.
    • Create a test app and run it.
    • Go to Product > Archive
    • Select the app you archived on Visual Studio from the list.
    • Select Distribute App button.
  • taitotaito USMember ✭✭

    Still not working:

    2019-09-26 15:33:38.362 altool[62528:4432964] Using tool '/Applications/'.
    2019-09-26 15:33:38.362 altool[62528:4432964] 'DTAppAnalyzerExtractor': self.executablePath: /Applications/
    2019-09-26 15:33:38.363 altool[62528:4432964] Launching: /Applications/ --input-dir /var/folders/_1/7_lm5w6j5px21sd311p2g7340000gn/T/xxx.iOS-4.ipa --output-file /var/folders/_1/7_lm5w6j5px21sd311p2g7340000gn/T/
    2019-09-26 15:33:42.725 altool[62528:4432963] Web service call (validateSoftwareSPIUsage) result: (null)
    2019-09-26 15:33:42.856 altool[62528:4432963] Using template named: purple-metadata-template
    2019-09-26 15:33:42.858 altool[62528:4432956] Sending request to iTunesTransporter...
    2019-09-26 15:33:42.859 altool[62528:4432956]     Command: /Applications/
    2019-09-26 15:33:42.859 altool[62528:4432956]   Arguments: -m upload -u '[email protected]' -vp json -TxHeaders eyJqZW5xxxxxXRlIjoicHYifQ== -sessionid @env:0028Bxxxxx8D1xxxxxxx-BFxxxxA75 -sharedsecret @env:xxxxxxxx -f '/var/folders/_1/7_lm5wxxxxp2g7340000gn/T/8B0E8xxx4AD7-A547-4xxBD53/1219768922.itmsp' -indicator true -v eXtreme -Dtransporter.client='altool' -Dtransporter.client.version='4.00 (1181)'
    2019-09-26 15:33:45.901 altool[62528:4432953] [2019-09-26 15:33:45 MESZ] <main>  INFO: Configuring logging...
    2019-09-26 15:33:45.914 altool[62528:4432953] [2019-09-26 15:33:45 MESZ] <main>  INFO: Logging level set to eXtreme

    Stuck here, no network traffic

  • taitotaito USMember ✭✭

    According to the Apple Developer Forums, App Store Connect seems to be down with the current XCode version.

  • My solution as below:
    1.Go to and login
    2. Security -> App specified PW -> type in anything it will generate a PW for IPA upload
    3. Go application loader, copy and paste the auto-generate PW

  • KingamattackKingamattack Member ✭✭

    You can also download a second version of Xcode (10.3) and use its Application Loader

  • DuaneCrawDuaneCraw USMember

    There was a comment in the release notes to the effect that the build tooling should handle it. I tried to archive and distribute from VS2019 on Windows, and got a file path length error, so that doesn't seem to work. I did install Xcode 10.3 to get the loader back, we'll see if I can deploy with it.

  • DuaneCrawDuaneCraw USMember

    Update, The loader from 10.3 seemed to work great for me

  • XamFormCoderXamFormCoder USMember ✭✭

    @drwehmeyer said:
    I have the same issue but try to have a look at this command:

    xcrun altool --upload-app --type ios --file "path/to/application.ipa" --username "YOUR_ITMC_USER" --password "YOUR_ITMC_PASSWORD"

    I did not try it myself yet, but will properly do it later today or tomorrow so I can update my app.

    This command worked fine for me with the new xCode.
    Just remember you need an APP PASSWORD, not your usual AppleId one.

  • PaulDistonPaulDiston USUniversity ✭✭✭✭
    edited October 2019

    @DuaneCraw Would you be able to share how you installed XCode 10.3 along side XCode 11?

    Update : I have managed to download and install version 10.3 of XCode and I am trying to upload my IPA to the App Store using Application Loader. The following thread seems to be related to the issue I was experiencing with the Distribute option from Visual Studio 2019 :-

  • DuaneCrawDuaneCraw USMember

    1) Go to -> Develop -> Downloads -> More
    2) Search for Xcode and download "Xcode 10.3.xip"
    3) Move the xip file to a folder where you want 10.3 setup, and double click to expand xip file
    4) In Finder use "Show Contents" open the xcode folder
    5) Loader is under /Contetns/Applications

  • I am able to use Visual Studio to distribute my app.
    Still need to get the App Specific password from the apple id account page.

    Using Visual Studio 2019 - 16.3.2
    Mac running Catalina Beta
    Xcode 11

  • PaulDistonPaulDiston USUniversity ✭✭✭✭

    @MikaelDavidsson Did you run into any issues with paths being too long when Distributing from Visual Studio 2019 on a PC? If you did, how did you resolve those issues?

  • PaulDistonPaulDiston USUniversity ✭✭✭✭
    edited October 2019

    @DuaneCraw Thank you very much for the steps you provided. I had originally installed XCode 10.3 however when pairing with the Mac again after a reboot, Visual Studio 2019 on the PC complained that the version of XCode was now out of sync. So instead of installing XCode 10.3, I can, according to your instructions, open the Application Loader directly from the uncompressed XIP folder, using Show Package Contents. Although the Application Launcher opens I am yet to try uploading a IPA. My previous successful upload was after I had installed XCode 10.3 fully.

    Update : I have now successfully uploaded a new IPA using the Application Loader opened via the Show Package Contents method mentioned above.

  • I did not have any issues with the path.
    My .ipa file path is at 89 characters only. (Path, not including filename)

  • EsamSherifEsamSherif EGUniversity ✭✭

    use Transporter available on app store

Sign In or Register to comment.