I can't find my Signing Identity and my Provisioning Profile when I want sign my Bundle manually

tombyrstombyrs Member ✭✭

Hello,

After several hours of research, I succumb, and I beg the Xamarin community to save me from madness (I exaggerate may be a little).

Visual studio can not find my "Signing Identity" and my "Provisioning Profile" when I want sign my Bundle manually in the "iOS Bundle Signing" section in the "properties" page of my iOS project.

More infos about my situation :

  • I work on Windows 10 with Visual Studio 2019 and I pair my macOS Catalina 10.15
  • I have an Apple Developer Account and I create Certificates, Identifiers and Profiles for my App.
  • I can see them in the details of Apple Accounts (Tools>Options>Xamarin>Apple Accounts).
  • I have installed .cer and .mobileprovision on my Mac.
  • In the info.plist, I referenced the Bundle Identifier that matches the one in my profiles.
  • I already deleted the bin and obj folder after clean my project and restart VS.

Someone has a solution ?
Thanks in advance.



Best Answer

  • tombyrstombyrs ✭✭
    Accepted Answer

    The problem is solved by a simple upgrade of Visual Studio (to 16.3.5).

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    It seems the development certification has been successfully installed on your Mac.
    Can you deploy the project with the same bundle ID using XCode to your real physical device?
    And you can try this project on VS for Mac.
    Maybe some configurations of Mac hasn't been correctly set. Try to reboot on both sides and test again.

  • tombyrstombyrs Member ✭✭

    Hello LandLu,

    Thanks for the response.
    I can deploy the project to a real physical device with automatically signing, but I want to specified the profile for upload my IPA file to the App Store Connect.

    I opened my project on VS for Mac and I can find my profiles.
    But it's not practical to open it on Mac everytime when want build. I would like find my profiles on my Windows VS.
    After reboot on both sides, nothing changed.

  • tombyrstombyrs Member ✭✭
    Accepted Answer

    The problem is solved by a simple upgrade of Visual Studio (to 16.3.5).

Sign In or Register to comment.