Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Firebase Messaging is causing a crash

coosmiyncoosmiyn Member ✭✭

I get this error in the console when I try to deploy the app, tried both on simulator and physical device. It displays the splash image then it backgrounds the app. No exception is thrown, the debugger just disconnects.

It seems that this only happens when I use Firebase Messaging. If I delete any of the code related to Firebase Messaging (but not deleting the NuGet) it works as intended.

I am using Visual Studio for mac, the ios 13 sdk and the latest Firebase NuGets. Tried downgrading but nothing helps.

Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000 Exception Note: EXC_CORPSE_NOTIFY Termination Description: DYLD, dependent dylib '@rpath/protobuf.framework/protobuf' not found for '/private/var/containers/Bundle/Application/DA138C0F-1292-4C17-A793-0443C743F7F6/ClubHub.iOS.app/Frameworks/FirebaseMessaging.framework/FirebaseMessaging', tried but didn't find: '/private/var/containers/Bundle/Application/DA138C0F-1292-4C17-A793-0443C743F7F6/ClubHub.iOS.app/Frameworks/protobuf.framework/protobuf' '/private/var/containers/Bundle/Application/DA138C0F-1292-4C17-A793-0443C743F7F6/ClubHub.iOS.app/Frameworks/FirebaseMessaging.framework/Frameworks/protobuf.framework/protobuf' '/private/var/containers/Bundle/Application/DA138C0F-1292-4C17-A793-0443C743F7F6/ClubHub.iOS.app/Frameworks/protobuf.framework/protobuf' '@rpath/protobuf.framework/protobuf' '/System/Library/Frameworks/protobuf.framework/protobuf' Highlighted by Thread: 0

Yesterday I was getting a different error in the console:

*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '+[FIRApp registerAsConfigurable:]: unrecognized selector sent to class 0x11034d9e8' *** First throw call stack: ( 0 CoreFoundation 0x00007fff23b98bde __exceptionPreprocess + 350 1 libobjc.A.dylib 0x00007fff503b5b20 objc_exception_throw + 48 2 CoreFoundation 0x00007fff23bb9604 +[NSObject(NSObject) doesNotRecognizeSelector:] + 132 3 CoreFoundation 0x00007fff23b9d7bc ___forwarding___ + 1436 4 CoreFoundation 0x00007fff23b9f6c8 _CF_forwarding_prep_0 + 120 5 libobjc.A.dylib 0x00007fff503bcdf0 load_images + 1226 6 ??? 0x0000000110c24d79 0x0 + 4576136569 7 ??? 0x0000000110c31970 0x0 + 4576188784 8 ??? 0x0000000110c30786 0x0 + 4576184198 9 ??? 0x000<…>

Posts

  • EdalzebuEdalzebu Member ✭✭
    edited October 2019

    I have the same issue with this.

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY
    Termination Description: DYLD, dependent dylib 'rpath protobuf.framework/protobuf' not found for '/private/var/containers/Bundle/Application/79123E84-9651-424A-8424-D152D3AF5F5B/AnApp.app/Frameworks/FirebaseMessaging.framework FirebaseMessaging', tried but didn't find: '/private/var/containers/Bundle/Application/79123E84-9651-424A-8424-D152D3AF5F5B/AnApp.app/Frameworks/protobuf.framework/protobuf' '/private/var/containers/Bundle/Application/79123E84-9651-424A-8424-D152D3AF5F5B/AnApp.app/Frameworks/FirebaseMessaging.framework/Frameworks/protobuf.framework/protobuf' '/private/var/containers/Bundle/Application/79123E84-9651-424A-8424-D152D3AF5F5B/AnApp.app/Frameworks/protobuf.framework/protobuf' 'rpath protobuf.framework/protobuf' '/System/Library/Frameworks/protobuf.framework/protobuf'
    Highlighted by Thread: 0

  • EdalzebuEdalzebu Member ✭✭

    So I downgraded the Xamarin.Firebase.iOS. packages. iOs.Core to 5.1.3 and it seems to be working fine. Seems version 6.1 has some kind of issue.

  • coosmiyncoosmiyn Member ✭✭

    Just Firebase Core? I remember doing that. What are the Firebase NuGets you are using and also what version of Xamarin iOS and what SDK? :D

  • EdalzebuEdalzebu Member ✭✭

    I am using the next packages:

    • Xamarin.Firebase.iOS.CloudMessaging (3.1.2)
    • Xamarin.Firebase.iOS.Core (5.1.3)
    • Xamarin.Firebase.iOS.InstanceID (3.2.1)

    So i uninstalled all the Firebase packages, then i made sure the bin and obj folders were empty, continued installed this versions i listed before and seems to be working.

    My SDK version is 13.0

    Xamarin.iOS version is 13.2.0.47

  • RemeesRemees Member ✭✭

    Any Update on this issue, Is it possible to use the latest version of firebase core(6.1.0)?

  • Udi_IdanUdi_Idan ILMember ✭✭

    Any update? Did someone succeed in using the latest version of these libraries?

Sign In or Register to comment.