Forum General

Not able to log in to Xamarin Acccount getting "Please connect to the internet to proceed"

i have created new account and installed Xamarin and tried to open sample application with VS 2010 and VS 2013. It is asking me to SignIn. I tried to log in with my account, but I am getting Please connect to the internet to proceed.

please do the needful.


  • GiggioGiggio BRMember

    Same problem here, error happens in Xamarin Studio and in Visual Studio 2013.
    Sometimes I am getting this error as well:

    System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
       at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors)
       at Xamarin.Components.Ide.Activation.ActivationService.<GenerateFullWorkflowSequence>d__89.MoveNext()
       at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step)
       at Xamarin.Components.Ide.Activation.ActivationDialog.<>c__DisplayClass13.<StartSpinnerTaskAndScheduleContinuation>b__12(Task t)

    Also happens in VS or XS.

    Is the server up? Is everthing working?

  • Same with me, won´t reach my deadline tonight because of this :( Also, I have 3 computers I work on; home pc and mac, office pc. When I switch between them I get a prompt saying I need business edition. If I go to account settings and remove the registrered computers they are added again and work. I have to repeat this almost every time I switch computers.

  • amilleramiller USXamarin Team Xamurai

    Hi @kamalakannanayyau‌, @Giggio‌ & @EivindHolt.0417‌,

    Our activation servers are currently down :( Our Web Team is working on resolving the error and I will update this thread once it has been fixed. I apologize for the delay due to the issue.

  • amilleramiller USXamarin Team Xamurai

    Hi again!

    It looks like the issue with the activation servers has been resolved. Please let me know if you are still running into any errors while trying to activate. Thanks!

  • yes. it is working. thanks.

  • AndrewGibsonAndrewGibson USMember ✭✭

    Getting this error today.

  • kishornkishorn USMember

    I am having the same issue. Is the activation SERVER down again????

  • Is there a web page for status of the activation server? I'm seeing this problem today.

  • amilleramiller USXamarin Team Xamurai

    Hi @DennisPalmer.7064,

    While we don't have a dedicated page on our site with the status of the activation server, it should be up and running now (I just checked on my side and was able to activate my Mac). Can you try activating again and let me know if the issue remains?

    Thanks in advance!

  • DennisPalmer.7064DennisPalmer.7064 USMember
    edited August 2014

    Still have the problem. I'm trying to run the F# t-shirt app. On Windows Server 2012 running on a Windows Azure VM. My laptop isn't powerful enough to run the Andriod emulator.

  • amilleramiller USXamarin Team Xamurai

    Hi @DennisPalmer.7064,

    I'm really sorry for the delay in running the Xamarin App Store Application, but it looks like we are still running into some issues with the server. As soon as I hear an update from our Web Team I will let you know.

  • BryanBryan USMember

    What's the status here? We're waiting on this coming back up.

  • amilleramiller USXamarin Team Xamurai

    Hi @Bryan,

    I do not yet have an update for you unfortunately :( As soon as I do, I will post back here.

  • CaseyPhamCaseyPham USMember

    Yup, I'm getting this message as well on Parallels installation of VS2012 Ultimate.

  • TvdHTvdH USMember

    Same problem.

    Xamarin.VisualStudio.Shell.ShellPackage Error: 0 : [2014-08-13 13:01:36.7] Failed to update Android license: Timeout.

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    I have the same problem but only on my Windows machine. On Mac i can connect to my Xamarin Account.

  • amilleramiller USXamarin Team Xamurai

    Hi @DennisPalmer.7064‌, @Bryan, @CaseyPham, @TvdH‌ and @RaphaelSchindler‌,

    Our Web Team has confirmed that the activation issue you were running into should now be resolved. If you attempt to re-activate the workstation and you do continue to run into activation issues, can you share the logs located in Xamarin Studio->Help->Open Log Directory ? Or, if you are trying to activate in Visual Studio, please share the logs from the following directory instead:


    The logs are needed because you are probably running into an issue that is separate from the one that was resolved.

    If you do not want to share the logs publicly, please send an e-mail to [email protected]

    And if you have specific account questions, please e-mail into the above address so we can take a look at your account. Thank you all for your patience while we worked through the issue :)

  • TvdHTvdH USMember

    I've managed to get it sorted through manual activation (mtouch --activate). I understand that sometimes there are issues with the activation servers however this should not prevent us from doing any work. That's not what we paid for.

    Also the manual activation was a good workaround yet it took a lot of googling to find this out from a non-xamarin support article.

  • sucharitrasucharitra USMember

    Hi ,

    I am getting below error time of log in.

    1.png 52.3K
  • hello anyone can solve my error of xamarin account login ..

  • DaveHuntDaveHunt USMember ✭✭✭✭✭


    Did you do as the error alert suggested and contact Xamarin Support? You'll likely get the issue resolved much faster that way than waiting for them to notice your post here.

  • I'm getting the same error now after 5 years from that post, i'm using visual studio 2015 community

  • how to fix this error when I log in to xamarin account in visual studio this error show please connect to the internet to process and the internet was connected

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Xamarin accounts are no longer supported as the component store has migrated to NuGet:

Sign In or Register to comment.