Forum Xamarin.Android


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Building Solution is a success, but when I run the solution in an emulator, it says build fails.

Build Failed: Xamarin.Android does not support running the previous version. Please ensure your solution builds before running or debugging it.

No errors in the error list, not sure what I'm supposed to do at this point.


  • fusionx86fusionx86 Member

    Thanks ruben_fonte, this helped me.

  • BrianConradBrianConrad USMember ✭✭✭

    I am getting this all the time with version 15.7.3 of VS 2017. Debug versions will run and Release won't. This even on solutions that built Release versions previously. Selecting x86 didn't help nor ARM for ARM emulators. It's like they rushed 15.7.3 so they could take an early summer vacation (very common in corporate America). This is very frustrating when trying to release an update for my customers. No builds including just simple ones want to work in release mode.

  • BrianConradBrianConrad USMember ✭✭✭

    Turns out we now have to sign the ARM version. I don't recall any need to this before just AdHoc and Google Play versions needed to be signed and you were prompted for those. BTW, I still get the message but the app runs (LOL).

  • loletmalupetloletmalupet USMember ✭✭

    @ruben_fonte said:
    Hey man,

    I had a similar problem and this fixed it:
    - Next to "Debug", if you have " Any CPU", Click on it and select "Configuration Manager"
    - You will see "Debug" and "Any CPU" again, click on "Any CPU" to open a dropdown list and choose the option "x86"
    - Then whenever you are running your App just make sure that x86 is selected next to "Debug"

    I hope this helps!


    Thanks @ruben_fonte!

  • Rahul_rathaurRahul_rathaur Member
    edited September 2019

    Thats Not working for Me. like debug on "x86"

  • subramanyamnuggusubramanyamnuggu Member ✭✭✭

    Hi @Rahul_rathaur
    Have you resolved the above issue,
    If yes, please let us know how to resolve that which will be great help for us.

  • subramanyamnuggusubramanyamnuggu Member ✭✭✭

    Hi @Dysprosium ,

    Have you found any solution for the issue which you posted. If yes please share that so that it will be very helpful for me because even I am facing the same problem and trying to solve that but no use.

Sign In or Register to comment.