Forum Xamarin.iOS

watchOS 5.3 Architecture Problems

Pad94Pad94 Member ✭✭


i have tried to install a simple App with 3 Buttons on my Apple Smartwatch 4 44m watchOS 5.3. The Smartphone is the Iphone 8 IOS 12.4.
On the simulator all is working fine, but on the real device following Error occurs at installing the WatchApp.

InspectingPackage - PercentComplete: 20% TakingInstallLock - PercentComplete: 20% PreflightingApplication - PercentComplete: 30% InstallingEmbeddedProfile - PercentComplete: 30% InstallingEmbeddedProfile - PercentComplete: 30% VerifyingApplication - PercentComplete: 40%
IncorrectArchitecture: Failed to find matching arch for 32-bit Mach-O input file /private/var/installd/Library/Caches/
error MT1006: Could not install the application '/Users/administrator/Projects/IphoneTest2019/IphoneTest2019/bin/iPhone/Release/' on the device 'iPhone': AMDeviceSecureInstallApplicationBundle returned: 0xe8000087 (kAMDIncorrectArchitectureError).

Maybe its because i cant choose watchOS 5.3 as destination build. I can only choose IOS 12.2 and watchOS 5.2. I dont know, ived tried lower versions, same error. On the simulator i can build the 5.2 watchOS on the 5.3 simulator.

You guys have some Ideas?

Thanks for help



  • Pad94Pad94 Member ✭✭

    This only happens if i run in Release Mode, if i run in Debug Mode all is working fine, but the App on the AppleWatch is not installed and dont start. Also i cant install from the WatchApp from Apple... on the top their is a message "Waiting on Debugger Port 10001..."

Sign In or Register to comment.