Installation of software item 'Xamarin.Android for Visual Studio and Xamarin Studio' failed

Hi,

I have tried everything I can think of but the Xamarin installer keeps failing. The problem seems to occur when installing 'mono-android-4.10.01073_signed.msi'. I'm hoping someone here can help.

These are the steps I was trying to take:

  • Upgrade from VS2010 to VS2013: Installed VS2013, but when opening it looks like I need to reinstall Xamarin tools.
  • Download the Xamarin Installer and run.
  • Installation Failed as described here.

I have also tried to uninstall Xamarin.Android but this also fails.

The relevant extract from the installlog:

[2013-12-19 11:01:28.167] [Info] END >>>>>> msiexec log: '\Temp\2\tmp3239.tmp'
[2013-12-19 11:01:28.167] [Info] Status: failed.
[2013-12-19 11:01:28.167] [Exception] Installation of software item 'Xamarin.Android for Visual Studio and Xamarin Studio' failed with exception.
[2013-12-19 11:01:28.167] [Exception] Xamarin.Web.Installer.InstallException: Installation of archive '\Temp\2\Xamarin\downloads\mono-android-4.10.01073_signed.msi' failed with exception. ---> System.InvalidOperationException: MSI execution failed.
[2013-12-19 11:01:28.167] [Exception] at Xamarin.Web.Installer.WindowsInstallationArchiveHandler.InstallMsi(String file, Boolean needsPrivileges)
[2013-12-19 11:01:28.167] [Exception] at Xamarin.Web.Installer.Installer.InstallationArchiveHandler.Install(String path, Boolean needsPrivileges)
[2013-12-19 11:01:28.167] [Exception] --- End of inner exception stack trace ---
[2013-12-19 11:01:28.167] [Exception] at Xamarin.Web.Installer.Installer.InstallationArchiveHandler.Install(String path, Boolean needsPrivileges)
[2013-12-19 11:01:28.167] [Exception] at Xamarin.Web.Installer.Installer.BaseSoftwareItem.Install(UInt32 tryNumber)
[2013-12-19 11:01:28.167] [Exception] at WindowsInstaller.ProgressPage.InstallationWorker()
[2013-12-19 11:01:28.168] [Info] Status: failed.
[2013-12-19 11:01:28.168] [Debug] Starting installation complete task.
[2013-12-19 11:01:28.168] [Info] Background installation worker completed.
[2013-12-19 11:01:28.268] [Info] Installation completed with failure
[2013-12-19 11:01:28.268] [Info] Status: failed.

Im on Windows Server 2008 R2 Standard SP1 x64. This is my build server and I'm trying to update it.

Maybe there is way to get more information about what is going wrong? Some other log I can have a look at?

Posts

  • Managed to solve this by uninstalling the '\Temp\2\Xamarin\downloads\mono-android-4.10.01073_signed.msi' and reinstalling it.

Sign In or Register to comment.