Forum Xamarin.Android

Logcat Device Log Problems

I've had a plethora of problems with the device log, and weirdly enough i can't find any answers to them, so I might be missing something obvious here.

First off, I cannot choose any Device in the "Choose Device" drop down, it only has "Choose Device" as its only option. This occurs even when I have a device running.

Hence all the buttons are not enabled and are greyed out.

There's no info being outputted whats so ever.
Furthermore, from what I understand I should also have access to a couple of filter options as well, that I do not have access to.

Answers

  • JarvanJarvan Member, Xamarin Team Xamurai

    Could you post a screenshot to display the problem?

  • RobertPRobertP Member

    I have this same problem. I've attached a screenshot. You can see the emulator is running. The device monitor is connected. VS2019 is connected to the device. And even an 'adb logcat' can display the log. But the device never appears in the Device Log dropdown.!

    Edit: I can't post the link to the pic, I "have to be around a little while longer..." GRR (https : //us.v-cdn.net/5019960/uploads/editor/i5/o8dcobh56y2b.png

  • kidpurekidpure Member
    edited November 2019

    I have this exact same issue, here is a picture:

    When I type "adb devices" in the command line it says: 'emulator-5554 device.'

  • kidpurekidpure Member
    edited November 2019

    @Jarvan said:
    Could you post a screenshot to display the problem?

    Ayo, I displayed one above, got any ideas?

    • Cheers, :smiley:
  • ZackeryPZackeryP Member

    ​Hello all, after struggling with this I found a solution that has worked for me every time thus far:
    Firstly you need to go to your .android location, one quick way to get there is by going to your device manager, right-click on a device and select "Reveal in Explorer"
    Then delete everything INSIDE OF the .android folder, not the folder itself.
    After deleting that data, simply go back into visual studio, open device manager and create a new device. It should show in the debug area, so click run and once loaded, or partially loaded it should then show that device in the Device Log "Choose Device" area.

    This worked for me at least, hopefully, this clears it up for some.

Sign In or Register to comment.