Failed to deploy app on iPhone from VS

Hi

We use Xamarin ios since 4 month. I updated the software and now I meet strange issue.
I'm working with Visual Studio 2012 on a windows 7 computer. I connect my mac with visual studio. I connect my iPhone developper to the mac, and it appears on VS. I selected it, and run on debug. And I get this:

Remote build finished...
Debugging session ended.
Debugging session ended.
Le programme '[5776] myAppiPhone.vshost.exe: Managé (v2.0.50727)' s'est arrêté avec le code -1 (0xffffffff).

It seems that VS can not get the Signing identity.

This project compile and work on xamarin studio on the mac.

Does anyone have problems like this?

Posts

  • I have been having the exact same issue. Using the latest stable version of Xamarin.iOS for Visual Studio I have been unable to deploy on device.

    Would be nice to get an official response on this.

  • sean-sparkmansean-sparkman US
    edited December 2013

    Having the same issue. I am run it from VS in the simulator. I can deploy from Xamarin Studio and XCode on my Mac Mini onto the device.

    On Windows Box...
    Visual Studio 2012 Update 4
    Xamarin iOS 1.8.365 in Visual Studio

    On Mac Mini (Maverick)
    Xcode 5.0.2 (3335.32) Build 5A3005
    Xamarin Studio 4.2.2 Build 2
    Xamarin.iOS 7.0.4.209 (Business Edition)

    [18-Dec-2013 14:31:07] Extracting embedded content

    [18-Dec-2013 14:31:07] Error: No provisioning profiles have been detected. Please visit the iOS Provisioning Portal at http://developer.apple.com to create one.

    [18-Dec-2013 14:31:07] No provisioning profile

    [18-Dec-2013 14:31:07] Error: No provisioning profiles have been detected. Please visit the iOS Provisioning Portal at http://developer.apple.com to create one.

    [18-Dec-2013 14:31:07] Comm

    and [Build: CommmandUrl=Build] finished (49)

  • Nevermind... I had to put my Apple ID into the Accounts under Preferences. Odd that I could deploy from Xamarin Studio to the device without that?

Sign In or Register to comment.