Xamarin ios DuplicateIdentifier debug problem

I got a problem. I cannot upload my application to the device to check it or debug. Error I get is:
DuplicateIdentifier: Found bundle at /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.fbbOLm/extracted/DEIMIC.iOS.app/Frameworks/Xamarin.framework with the same identifier (xamarin.ios.xamarin-framework) as bundle at /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.fbbOLm/extracted/DEIMIC.iOS.app/Frameworks/Xamarin-debug.framework

Tried deleting bin/obj directories, but it doesn't help.

What is interesting I can create IPA file and upload it to the Appstore and download it using TestFlight, but my today extensions doesn't work. I think it is connected to this error: https://developercommunity.visualstudio.com/content/problem/526872/xamarin-ios-duplicateidentifier-attempting-to-debu.html

Does anyone know how to fix it?



  • LucasZhangLucasZhang Member, Xamarin Team Xamurai

    What are the version of VS and Xcode ?

  • AleksanderDejewskiAleksanderDejewski USMember ✭✭

    I tried a few:

    • VS for Mac(8.1)
    • VS 2019(Windows)
    • VS 2017(Windows)

    XCode version is 10.2.1

    All give same error.

  • LucasZhangLucasZhang Member, Xamarin Team Xamurai

    Can you confirm that your app extension project does not use the same bundle ID as your main app project?

  • AleksanderDejewskiAleksanderDejewski USMember ✭✭

    Yeah, all identifiers are different.

    After all I managed to fix it by removing today extension and adding it one more time. No idea what was wrong. Probably some garbage in my today extensions configuration.

Sign In or Register to comment.