Forum Xamarin.Forms

[XF] VM has multidex support, MultiDex support library is disabled Error

CharwakaCharwaka INMember ✭✭✭✭✭

XF 3.4 | .NET Standard 2.0

When i Deploy Android APP in Debug|Release Mode its working fine, but when i built a package in Debug Mode and install ,App got Stuck at Splash Screen.Not sure whats Went Wrong Here.

Following is log

11-23 23:27:49.226: I/MultiDex(8265) : VM with version 2.1.0 has multidex support
11-23 23:27:49.226: I/MultiDex(8265) : install
11-23 23:27:49.226: I/MultiDex(8265) : VM has multidex support, MultiDex support library is disabled.
11-23 23:27:49.244: W/monodroid(8265) : Creating public update directory: /data/user/0/com.Bingo.Perks/files/.override
11-23 23:27:49.244: W/monodroid(8265) : Using override path: /data/user/0/com.Bingo.Perks/files/.override
11-23 23:27:49.245: W/monodroid(8265) : Trying to load sgen from: /data/user/0/com.Bingo.Perks/files/.override/libmonosgen-2.0.so
11-23 23:27:49.245: W/monodroid(8265) : Trying to load sgen from: /storage/emulated/0/Android/data/com.Bingo.Perks/files/.override/libmonosgen-2.0.so
11-23 23:27:49.245: W/monodroid(8265) : Trying to load sgen from: /storage/emulated/0/../legacy/Android/data/com.Bingo.Perks/files/.override/libmonosgen-2.0.so
11-23 23:27:49.245: W/monodroid(8265) : Trying to load sgen from: /data/app/com.Bingo.Perks-ycPSjj78h2r1AWU-KkQvIA==/lib/arm64/libmonosgen-2.0.so
11-23 23:27:49.252: A/monodroid(8265) : No assemblies found in '/data/user/0/com.Bingo.Perks/files/.override' or '/storage/emulated/0/Android/data/com.Bingo.Perks/files/.override'. Assuming this is part of Fast Deployment. Exiting...
11-23 23:27:49.267: D/EmbryoManager(1202): prepare com.Bingo.Perks user 0

Answers

  • BillyLiuBillyLiu Member, Xamarin Team Xamurai

    @Charwaka

    have you tried to enable multidex?
    You could find it by right click your android project, then click Properties->Android Options->Packaging properties->Enable Multi-Dex

  • CharwakaCharwaka INMember ✭✭✭✭✭
    Yeah I enabled and set 1g also .
  • KhalidHexKhalidHex Member ✭✭

    @Charwaka Same problem ... how did you fix it ?

  • SagarPanwalaSagarPanwala USMember ✭✭✭

    @BillyLiu : Any update on this please ? This is frustrating, by every update something get breaks. :neutral:

  • CharwakaCharwaka INMember ✭✭✭✭✭

    Unistall the App, Try Incrementing App Version and reinstall again

Sign In or Register to comment.