Forum Xamarin.Android

"No package found" using Java Bindings Library and Android Library Project

ach00ach00 USMember
edited January 2014 in Xamarin.Android

I would like to reference an Android Library Project in my Xamarin Android App. I followed steps detailled in the documentation by building a ZIP file with "bin" and "res" folders. I don't have issues at generation but I get a "BINDINGSGENERATOR : warning BG8601: No packages found."

Can you please help me with this?

Thank you in advance


  • BurridgeBurridge USMember
    edited April 2014

    is it in your jar folder?

  • Hi,

    I'm getting exactly the same error. Even with a very simple jar file and an otherwise empty Library Bindings project. Yes, the jar is in my Jars folder. All suggestions are most welcome.


  • TomWernerTomWerner USMember
    edited June 2014

    I would also like to know the solution for this, I am having no luck. I am getting the exact same error, my Jar is in my Jars folder.

  • TimothyParezTimothyParez HKMember

    Exactly the same problem here

  • jameszhoujameszhou CNMember ✭✭


  • RAPIDDevRAPIDDev USMember ✭✭

    Any update?

  • MichaelRibbons.8567MichaelRibbons.8567 AUMember ✭✭
    edited February 2015


    A few days ago I was able to create an android bindings library for a particular .jar without issue.

    I attempted to make a new library in order to post a question sample on github, now JarToXml won't generate anything:

    1>JARTOXML : warning J2X9001: Couldn't load class device/scanner/ScanConst : java.lang.ClassNotFoundException: device.scanner.ScanConst
    1>JARTOXML : warning J2X9001: Couldn't load class device/scanner/ScannerService : java.lang.ClassNotFoundException: device.scanner.ScannerService
    .... (Same error for all classes in .Jar)

    1>BINDINGSGENERATOR : warning BG8601: No packages found.
    I'm totally confused because in one project I can generate the bindings, yet in another I can't.

    Jar file:

    A lot of people are interested in this - Is there a reason why there are so few answers?

    As mentioned in another Bindings Library post, I am having some luck with enabling MSBuild Diagnostic output:

    I'll post back when I get through all the exceptions.

  • MichaelRibbons.8567MichaelRibbons.8567 AUMember ✭✭
    edited February 2015

    Turns out the problem was the path of the 2nd binding library project - Java doesn't like #.

    Maybe the build process could check the path for # before executing JarToXml?

    I spent a fair bit of time on this one.

  • LuisFonsecaLuisFonseca PTMember

    I'm having the same issue and the path doesn't seem to have anything to do with it. Anyone found another fix for this? There are literally dozens of similar threads with the same problem, all unanswered! :neutral:

  • I am facing the same problem. Any update ?

  • kalkunkalkun DKMember ✭✭

    me 2, trying to bind braintrees android sdk!!

  • Check your binding project's setting for "Compile using Android version". You must have the SDK build tools installed for the version you are attempting to bind.

  • aquabayaquabay AUMember ✭✭

    Be sure to set the ZIP file "Build Action" in properties to "LibraryProjectZip", then rebuild.

Sign In or Register to comment.