Forum Xamarin.Android

An error occurred trying to load the page. Index was outside the bounds of the array.

I'm building a mobile application using Xamarin Form.When I tried to open AndroidManifest.xml in Visual Studio 2019 Community by Right Click -> Xamarin.Android Project -> Properties -> Android Manifest , I'm getting following error,

"An error occurred trying to load the page. Index was outside the bounds of the array."

But the application is working perfectly, just does not show the Android Manifest in properties.

I have try recreate the Android Manifest again and replace the old Manifest in Xamarin.Android but it still does not resolve the problem.

I have delete bin and obj file of Xamarin.Android but still problem persist.

I have create another new Xamarin Form and try to read the AndroidManifest.xml from properties and I can read it. But It just does not show in Xamarin Form my project

1. I have check the Xamarin Log in Visual studio by going too Help -> Xamarin -> Open Logs . It do show some error log.

Can anyone help me regrading this problem. I have attached the Xamarin Log regarding the problem and include the Android Manifest

Android Manifest

<?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="" android:versionCode="1" android:versionName="1.0.0" package="com.companyname.VMS.ResidentMobileApp" android:installLocation="preferExternal"> <application> <provider android:name="" android:authorities="${applicationId}.fileprovider" android:exported="false" android:grantUriPermissions="true"> <meta-data android:name="" android:resource="@xml/file_paths"></meta-data> </provider> </application> <uses-sdk android:minSdkVersion="18" android:targetSdkVersion="26" /> <uses-permission android:name="android.permission.INTERNET" /> <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" /> <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" /> <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" /> <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" /> <uses-permission android:name="android.permission.CAMERA" /> <application android:label="VMS.ResidentMobileApp.Android"></application> </manifest>


  • jezhjezh Member, Xamarin Team Xamurai

    Could you please post a basic demo so that we can try to reproduce this question ?

  • ThiyraashThiyraash Member ✭✭

    Hi jezh, thanks for the reply.
    I have run the project in VS2017 still giving same result. I try another computer with VS2019 and VS2017 still the same. I try to reproduce a small demo with this issue, but other project is working perfectly. I can view Android Manifest in properties for other project. This issue only happen in my project. I cannot share directly my project. So i will try to reproduce s small sample and share it.

  • jezhjezh Member, Xamarin Team Xamurai

    OK, I am waiting for your small sample.

  • meirrotfleischmeirrotfleisch USMember ✭✭✭


    I am having this same problem . Did you find the solution?



  • dirar99dirar99 Member ✭✭

    Your manifest file has two application tags. That is not allowed. See Documentation :

Sign In or Register to comment.