Publishing problem , Callkit is included even we are not using it

Good afternoon everyone today we have received a call from Apple saying that Callkit, included in our app, will block the app approval process.

Apple discovered an issue with Callkit and all the apps with a reference to callkit won't be published.

The problem is that we aren't using callkit but it's included in the assembly Xamarine.Ios , the main assembly for an Ios Xamarine project.

Is there a way to go over this problem by your opinion, by removing or similar stuff this reference?
Thank you very much for your appreciated help

Posts

  • nickelnextnickelnext ✭✭ CHMember ✭✭

    same here
    Using xlabs and xamarin forms

  • TpmsEuroshopTpmsEuroshop ITMember

    I am not an expert but do you think Apple will accept a package compiled with the previous sdk. There the call kit is not included. Luca

  • TpmsEuroshopTpmsEuroshop ITMember

    Last sentence was question, sorry

  • JWhiteJWhite Xamurai USMember, Xamarin Team Xamurai

    Hi All,

    Could you confirm that you have the Linker enabled? This should remove all traces of CallKit unless you are indirectly using it. Could you confirm that and get back?

    Warm regards,

  • SebastienPouliotSebastienPouliot Xamurai CAXamarin Team Xamurai

    @TpmsEuroshop by default your device builds (including the one you submit to Apple) should have the managed linker enabled (with Link SDK setting).

    That will remove any trace of CallKit (and a lot of other unused stuff) from the Xamarin.iOS.dll that ships with your application - unless it's used (in which case the linker won't be able to remove it).

  • TpmsEuroshopTpmsEuroshop ITMember

    Thanks a lot today we will try it!
    I will let you know

  • SarahSaydonSarahSaydon MTMember

    @JamesWhite From where can check the linker? Due i have the same issue

    Thanks

  • JGoldbergerJGoldberger Xamurai USMember, Forum Administrator, Xamarin Team, University Xamurai

    @SarahSaydon

    Look in your iOS Project Options -> iOS Build page for the Linker Behavior field. It should be set to "Link Framework SDKs Only" for release builds.

  • SarahSaydonSarahSaydon MTMember
    edited June 2017

    @JGoldberger

    Thanks

  • LeRondPointLeRondPoint ✭✭ USMember ✭✭

    I used this thread to figure out why our app wasn't launching on older simulators. Turns out MetalKit was included in the build because linking was deactivated in debug. MetalKit doesn't work in the simulator and this prevented running iOS 9 & iOS 10 simulators.

    Hopefully this will help others too.

Sign In or Register to comment.