Forum Xamarin.Android

How to determine of Dotfuscator worked

RonNYCRonNYC Member ✭✭✭

I tried to obfuscate my app's main DLL. But while Dotfuscator seems to work and outputs a dll to the obfuscated directory, in fact when I run ildasm against the DLL I can see everything just as before. So, what is being obfuscated?

Perhaps Confuser is better?



  • jezhjezh Member, Xamarin Team Xamurai

    Have you used the Dotfuscator correctly?

  • RonNYCRonNYC Member ✭✭✭
    edited March 2019

    I went through the installation as referenced here:

    All I know is the procedure names are still there unobfuscated.

    I thought that by installing it it would invoked after a compile but before packing (when using Archive).

    But Archive compiles the code to a new DLL and then packages it.

    When I examine that DLL in ildasm, everything is there in plain sight.

    I wanted to use Phoenix Protecter instead of DotFuscator. I think Phoenix does a better job (by comparison within ildasm). HOWEVER, if I put a command line in the post-build section, the archiving process fails.

    The command line calls Phoenix Protector on the DLL and then copies that DLL back to the main release directory. But that causes a linker error.

    How do I get Dotfuscator to run? I go to Tools->Dotfucscator and choose the app's dll. I save the project as dotfuscator.xml. I examine the xml and it seems correct. BUT when rebuilding or Archiving, Dotfuscator does not run. How do I make it run?

    I add an item to the csproj file referencing the dotfuscator xml file.

    BUT after the build, the main app DLL is still unobfuscated.

    I tried following directions here:

    But that made matters worse. VS could not load the build file.

Sign In or Register to comment.