Forum Xamarin.Android

Error: Attribute has already been defined (APT0000)

At work, I switched branches and now I can't build any branch due to:

error: Attribute "text" has already been defined (APT0000) Resources/values/attrs.xml
error: Attribute "closeIcon" has already been defined (APT0000) Resources/values/attrs.xml
error: Attribute "text" has already been defined (APT0000) Resources/values/attrs.xml

The other seven developers don't have this issue.

I've done the following:

  1. Deleted obj/Debug folder to clear out resource cache files and rebuilt
  2. Removed all packages and deleted them and rebuilt
  3. Deleted Visual Studio Community for Mac and reinstalled
  4. Deleted the repository and cloned it again and rebuilt

Anyone else have something to try? I've run out of ideas.

Posts

  • DavidClarkeDavidClarke NZBeta, University ✭✭

    I assume you ultimately resolved this issue - what fixed it for you?

  • I used a different computer.

  • DavidClarkeDavidClarke NZBeta, University ✭✭

    Oh dear, that's not really an option for me.

  • PhilipHadleyPhilipHadley USUniversity ✭✭

    I ran into this issue after making a change to our Android app to target API level 28, and upgrading all the associated Xamarin.Android.Support.* NuGet packages. While it built on my dev box, it failed to build (with this error) on our build server (Mac Mini). I was able to resolve the issue by upgrading our build server with the latest Android SDK Tools.

Sign In or Register to comment.