How to deploy to my plugged in phone and not to the emulated android?

RonNYCRonNYC Member ✭✭✭

In Visual Studio when I want to run my project, my only choice now is the Android_Accelerated_X86_Oreo emulator. I would like to deploy to my cell phone. I have been able to do that but suddenly I cannot. I have Dev Options enabled and the USB connection is in File Transfer mode. What am I doing wrong?

Answers

  • JohnHardmanJohnHardman GBUniversity mod

    @RonNYC said:

    In Visual Studio when I want to run my project, my only choice now is the Android_Accelerated_X86_Oreo emulator. I would like to deploy to my cell phone. I have been able to do that but suddenly I cannot. I have Dev Options enabled and the USB connection is in File Transfer mode. What am I doing wrong?

    On the Android device, in the Developer options page in Settings, have you got "USB debugging" turned on? If not, turn it on.
    If it's already turned on, disconnect and reconnect the USB cable. If you don't see the prompt appear on the device about allowing USB debugging, disconnect the USB cable from the PC and plug it into a different port (I don't know why, but that solves it sometimes).

  • DipakPatilDipakPatil Member ✭✭

    change the device.

  • D3nnisD3nnis USUniversity ✭✭✭
    edited March 7

    You can force to search for connected devices by typing adb devices in the command line.
    You can find adb in the platform-tools folder where you installed Android if it doesn't find the command.

    Type where adb.exe to find the location on your computer.

  • RonNYCRonNYC Member ✭✭✭

    thanks!!!!!!!!!!!!!

  • RonNYCRonNYC Member ✭✭✭

    Current ADB version is 1.032 on my computer.

    My phone is plugged in; USB debugging is turned on, the phone is accessible yet...only the emulator is found.

Sign In or Register to comment.