An error occurred while retrieving package metadata for 'name.atsushieno.proguard.facebook.5.3.2.2'

this issue raised when I am trying install or un-install any package any one could guide me why this happen , I face many issues when I update support design library to version 24.2.1

first it force me to make my compile target to Noguat api 24

second it force me to download this library even I dont enable progaurd

and cause many issues with support library

please help I wast my time fixing Xamairn issue

Best Answer

Answers

  • RofiqSetiawanRofiqSetiawan USMember ✭✭✭

    please, lists all of installed packages (nugets) in your project.
    remove all packages and re-add they back sometime could help.

  • minaFawzy.1775minaFawzy.1775 USMember ✭✭
       <?xml version="1.0" encoding="utf-8"?>
        <packages>
          <package id="Bolts" version="1.4.0.1" targetFramework="monoandroid70" />
          <package id="Glide.Xamarin" version="3.7.0" targetFramework="monoandroid70" />
          <package id="HockeySDK.Xamarin" version="4.1.0" targetFramework="monoandroid70" />
          <package id="name.atsushieno.proguard.facebook" version="5.3.2.2" targetFramework="monoandroid70" />
          <package id="Refractored.Controls.CircleImageView" version="1.0.1" targetFramework="monoandroid70" />
          <package id="sqlite-net-pcl" version="1.2.0" targetFramework="monoandroid70" />
          <package id="SQLitePCLRaw.bundle_green" version="1.0.1" targetFramework="monoandroid70" />
          <package id="SQLitePCLRaw.core" version="1.0.1" targetFramework="monoandroid70" />
          <package id="SQLitePCLRaw.lib.e_sqlite3.android" version="1.0.1" targetFramework="monoandroid70" />
          <package id="SQLitePCLRaw.provider.e_sqlite3.android" version="1.0.1" targetFramework="monoandroid70" />
          <package id="Xam.Plugins.Android.ExoPlayer" version="1.5.8" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Animated.Vector.Drawable" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Compat" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Core.UI" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Core.Utils" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.CustomTabs" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Design" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Fragment" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Media.Compat" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.v4" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.v7.AppCompat" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.v7.CardView" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.v7.RecyclerView" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Android.Support.Vector.Drawable" version="24.2.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Facebook.Android" version="4.16.1" targetFramework="monoandroid70" />
          <package id="Xamarin.Facebook.AudienceNetwork.Android" version="4.16.1" targetFramework="monoandroid70" />
          <package id="Xamarin.GooglePlayServices.Ads" version="29.0.0.2" targetFramework="monoandroid70" />
          <package id="Xamarin.GooglePlayServices.Basement" version="29.0.0.2" targetFramework="monoandroid70" />
        </packages>
    
  • RofiqSetiawanRofiqSetiawan USMember ✭✭✭

    @minaFawzy.1775 said:

    this issue raised when I am trying install or un-install any package any one could guide me why this happen , I face many issues when I update support design library to version 24.2.1

    first it force me to make my compile target to Noguat api 24

    Support Design Library 24.x designed for project that targetting Android 7.0 (API 24 – Nougat)
    Support Design Library 23.x designed for project that targetting Android 6.0 (API 23 – Marshmallow)
    So, I thinks it's normal and not problem :)

    @minaFawzy.1775 said:

    second it force me to download this library even I dont enable progaurd

    I try to install all your packages to simulate your project.
    none ask dependecy to name.atsushieno.proguard.facebook
    so my guess it's safe to remove it.

  • minaFawzy.1775minaFawzy.1775 USMember ✭✭

    Can I mix between both of them Xamarin.Android.Support.v7.AppCompat target 24 , and Xamarin.Android.Support.Design target 23

  • RofiqSetiawanRofiqSetiawan USMember ✭✭✭

    @minaFawzy.1775
    unfortunately No.
    from information on https://www.nuget.org/packages/Xamarin.Android.Support.Design/23.4.0.1:
    1 of its dependency constrains is Xamarin.Android.Support.v7.AppCompat (= 23.4.0.1), so you have to install the same version.

  • minaFawzy.1775minaFawzy.1775 USMember ✭✭

    thank you but what shall I do now ?? delete all libraries and re-install it again

  • minaFawzy.1775minaFawzy.1775 USMember ✭✭

    I face this issue by editing my project file

    First delete this import

    <Import Project="..\packages\name.atsushieno.proguard.facebook.5.3.2.2\build\name.atsushieno.proguard.facebook.props" Condition="Exists('..\packages\name.atsushieno.proguard.facebook.5.3.2.2\build\name.atsushieno.proguard.facebook.props')" />

    and this error

     <Error Condition="!Exists('..\packages\name.atsushieno.proguard.facebook.5.3.2.2\build\name.atsushieno.proguard.facebook.props')" Text="$([System.String]::Format('$(ErrorText)', '..\packages\name.atsushieno.proguard.facebook.5.3.2.2\build\name.atsushieno.proguard.facebook.props'))" />
    

    <?xml version="1.0" encoding="utf-8"?>



    Debug
    AnyCPU
    8.0.30703
    2.0
    {4C09D83A-C61C-4FA7-A77D-530AA899B90D}
    {EFBA0AD7-5A72-4C68-AF49-83D382785DCF};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}








    ****

  • sucharithasucharitha Member ✭✭

    An error occurred while retrieving package metadata for 'Xamarin.Forms' from source 'InputKit'.
    Im getting this error can anyone help me ?

Sign In or Register to comment.