Deprecated API Usage - Apple no longer accepts submissions of apps that use QuickTime or QTKit APIs.

SauravAnandSauravAnand ✭✭USMember ✭✭

Hi there,

I'm trying to upload my macOS app to AppStore today but after successfully uploaded .pkg file using Application Loader to AppStore i've got below error message via email from Apple Support:

"Deprecated API Usage - Apple no longer accepts submissions of apps that use QuickTime or QTKit APIs."

I've tried to find out any possible thing by which i can find some reference of the mentioned APIs but had no luck. I have no clue why i'm getting this failure.

Project target framework: Xamarin.Mac Full.

I've tried few mmp arguments as well but no luck such as: "--registrar:dynamic" or "--linkplatform".

I'm now using mmp argument "--optimize=-trim-architectures" with Lipo solution to remove 32-bit architecture error from the project.

Searched for the same topic and found few of them but they didn't work for my app.

Please suggest me how may i remove this warning from my project. Please let me know if any further input is required from my side.

Thank you.

Answers

  • ChrisHamonsChrisHamons Xamurai USForum Administrator, Xamarin Team Xamurai

    So using --linkplatform should work with Release builds.

    Please post your version of Xcode \ XM and preferably a full build log as well.

  • SauravAnandSauravAnand ✭✭ USMember ✭✭

    @ChrisHamons Thanks for your response. As required please find below details:

    Visual Studio Community 2017 for Mac
    Version 7.7.4 (build 1)
    Installation UUID: 6c95fe9d-c0be-42cb-93aa-ec2a93d26359
    GTK+ 2.24.23 (Raleigh theme)
    Xamarin.Mac 4.4.1.178 (master / eeaeb7e6)

    Package version: 516000221
    

    Mono Framework MDK
    Runtime:
    Mono 5.16.0.221 (2018-06/b63e5378e38) (64-bit)
    Package version: 516000221

    NuGet
    Version: 4.8.0.5385

    .NET Core
    Runtime: /usr/local/share/dotnet/dotnet
    Runtime Versions:
    2.1.8
    2.0.5
    SDK: /usr/local/share/dotnet/sdk/2.1.504/Sdks
    SDK Versions:
    2.1.504
    2.1.4
    MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.16.0/lib/mono/msbuild/15.0/bin/Sdks

    Xamarin.Profiler
    Version: 1.6.4
    Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

    Updater
    Version: 11

    Apple Developer Tools
    Xcode 10.1 (14460.46)
    Build 10B61

    Xamarin.Mac
    Version: 5.2.1.15 (Visual Studio Community)
    Hash: d60abd198
    Branch:
    Build date: 2019-02-01 12:23:30-0500

    Xamarin.iOS
    Version: 12.2.1.12 (Visual Studio Community)
    Hash: 65ec520f
    Branch: d15-9
    Build date: 2018-12-05 12:06:09-0500

    Xamarin.Android
    Version: 9.1.4.2 (Visual Studio Community)
    Android SDK: /Users/vaibhavdomkundwar/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
    8.1 (API level 27)

    SDK Tools Version: 26.1.1
    SDK Platform Tools Version: 28.0.0
    SDK Build Tools Version: 27.0.3

    Microsoft Mobile OpenJDK
    Java SDK: /Users/vaibhavdomkundwar/Library/Developer/Xamarin/jdk/microsoft_dist_openjdk_1.8.0.9
    openjdk version "1.8.0-9"
    OpenJDK Runtime Environment (build 1.8.0-9-microsoft-b00)
    OpenJDK 64-Bit Server VM (build 25.71-b00, mixed mode)

    Android Designer EPL code available here:
    https://github.com/xamarin/AndroidDesigner.EPL

    Android Device Manager
    Version: 7.7.5.0
    Hash: 06ceaea1

    Xamarin Inspector
    Version: 1.4.3
    Hash: db27525
    Branch: 1.4-release
    Build date: Mon, 09 Jul 2018 21:20:18 GMT
    Client compatibility: 1

    Build Information
    Release ID: 707040001
    Git revision: 2a4679454f31c8bb887cfd181ea133c9149d3cad
    Build date: 2019-01-30 16:18:21+00
    Build branch: release-7.7.4
    Xamarin extensions: c8b4305fd4c60b9c25947072eb150fdc3a5aa2b5

    Operating System
    Mac OS X 10.14.0

    ==================================

    I'm also attaching full build log of release mode after setting mmp arguments as "--linkplatform" and it's clearly showing 1 error like:

    MMP : error MM2002: Failed to resolve assembly: 'Org.Mentalis.Security.Cryptography, Version=4.3.0.0, Culture=neutral, PublicKeyToken=2780ccd10d57b246'

    Thanks for your help.

  • ChrisHamonsChrisHamons Xamurai USForum Administrator, Xamarin Team Xamurai

    I'm having some difficulty tracking your issue, you said you tried --linkplatform but your log shows that build is a failure. That build shows a Org.Mentalis.Security.Cryptography library that some dependency of yours is depending upon that is not being included.

    For any form of linking to work, even the limited platform linking, you need to have all dependencies available for scanning. You need to fix your dependency graph to either include that assembly or fix the consumer to no longer link against it. This part is not a bug in Xamarin.Mac.

    Enabling the dynamic registrar at one point was also a valid work around for mac store submissions, I'm not sure why that didn't work for you.

Sign In or Register to comment.