Which svn does XS 4.3 try to pick up on?

nodoidnodoid ✭✭✭GBMember, Beta ✭✭✭

Hi,

I have both svn from macports and svn from Xcode installed on my mac. When I try to commit to svn, I am being told that I need to update my repo to v31 by XS.

Is this picking up on the svn from macports (which is running on 1.8) or from Xcode (running 1.7.10)? I don't want to do an update to the repo and have XS not be able to update to the repo.

Paul

Posts

  • MariusUngureanuMariusUngureanu Xamurai ROXamarin Team Xamurai

    XS picks up XCode's 1.7.

  • MariusUngureanuMariusUngureanu Xamurai ROXamarin Team Xamurai

    Also, there is no such thing as v31. Can you submit a screenshot with the information box?

  • nodoidnodoid ✭✭✭ GBMember, Beta ✭✭✭

    Pauls-Mac-mini:ftrack2-ios PFJ$ svn commit
    svn: E155021: This client is too old to work with the working copy at
    '/Volumes/Developer/Developer/ftrack2' (format 31).
    You need to get a newer Subversion client. For more details, see
    http://subversion.apache.org/faq.html#working-copy-format-change

  • nodoidnodoid ✭✭✭ GBMember, Beta ✭✭✭

    The odd thing is that the repo itself was last accessed with XS about 3 weeks ago (prior to the svn breakage on alpha when Mavericks came along)

  • MariusUngureanuMariusUngureanu Xamurai ROXamarin Team Xamurai

    Is the old repo still in 1.6 format? That might be the cause.

  • MariusUngureanuMariusUngureanu Xamurai ROXamarin Team Xamurai

    The proper fix for upgrading repository formats and announcing that working copies are too new is under progress. No ETA though.

Sign In or Register to comment.