Could not install package 'Xamarin.Android.Support.Compat 24.2.1'

aaravaarav INMember ✭✭

Could not install package 'Xamarin.Android.Support.Compat 24.2.1'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v6.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author. 0

Best Answer

Answers

  • vinothswamivinothswami Member ✭✭

    I too have the same problem

    the visual studio used - 2015
    target framework - 7.0
    install Nuget Google play map service tried to install 29.0.0.1/32.x.x.x/40.x.x.x/ 60.1142.0 nothing works

    2 days to fix this issue...

    Many things I checked as follows.

    1. Check the VS Android SDK manager whether targeted SDK is installed or not
    2. open -> Android SDK manager in VS -> go to extras -> install Google play services
    3. go to tools in VS -> options -> xamarin -> other -> click now for check for updates and restart the system not VS only.
    4. build your projects if google map again showing error, just select the google obj and press show potential fixes then take the last option as Using Android.gms.map which is already mentioned in the code.

    I hope this will fix because it's worked for me.

Sign In or Register to comment.