Unable to build any Xamarin.Forms app

GT85GT85 Member ✭✭

For a few days I cannot build anymore. Even a new empty Forms project (the one that displays « Welcome to Xamarin.Forms! ») displays the LaunchScreen.storyboard tab and 3 error messages:

ibtoold[8369:648873] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '+[SimServiceContext serviceContextForDeveloperDir:error:]: unrecognized selector sent to class 0x11396dc00'

It looks like this has begun after Xcode 10.0 was installed on my Mac (High Sierra 10.13.6, no pending update in the AppStore). I use Visual Studio Community 7.6.6 (build 17), no pending update in the stable channel. I cannot work anymore.

Any idea how to progress?

Tagged:

Posts

  • JohnHardmanJohnHardman GBUniversity mod

    @GT85 - I had the same error yesterday after upgrading VS2017, Xamarin.iOS and XCode. I didn't make a note of how I resolved it, but I think it was just a case of re-starting the Mac build server.

  • NMackayNMackay GBInsider, University mod

    Yeah, saw that but as John says, a reboot & made sure XCode was opened and did any pre-settings after upgrading to XCode 10.0, Also made sure VS on the mac was up to date.

    A clean, rebuild app project and then deploy and it worked fine.

  • GT85GT85 Member ✭✭

    Wonderful! I have rebooted, launched Xcode so that it could complete its installation, and everything works.
    Many thanks,
    Gilbert

  • Had the same issue today.
    Just had to open xcode after the update and complete the 'Installing additional components' process and the issue is gone. :) Thank you so much.

Sign In or Register to comment.