Forum Xamarin.Forms

Iphone device is not showing in debug list in project.

Hello,
I am creating an app for ios and android with help of xamarin.forms. When I am connecting my iphone device with my mac system for debugging the code it is not showing in the debug list. There is still showing Ios device. But if I open any other project of xamarin.forms Iphone option is showing in the debug list. I don't know why it is not showing only in one project. Is there any setting to enable the iphone device for project? Or any other way to manage iphone device with project?

Best Answers

Answers

  • NielsCupNielsCup NLMember ✭✭✭

    If your iPhone still does not show up: open iTunes while your phone is connected. It should ask you to connect to your phone. Allow it > select "trust computer" on your device > reconnect and your phone should be visible in Xamarin.

  • SteveShaw.5557SteveShaw.5557 USMember ✭✭✭
    edited September 2018

    On Mac, run XCode. Select menu Window / Devices and Simulators, Devices tab.

    Turn on your phone; connect your phone to usb. Xcode will say it is not paired; select "Trust" on iPhone.

    Now Xcode should pair it, and put it in the list. That takes awhile; progress shows in Xcode's Devices window.

    If it says "iPhone is busy; Preparing debugger support for iPhone" for more than 2 or 3 minutes, see https://stackoverflow.com/a/47448911/199364 for alternatives. Option #3 is the one I used.

    When that process is complete, it should now be listed in Xcode's list of devices.
    Then restart VS mac; open your iOS project; select config "Debug | iPhone".
    it should show up in list of devices, with same name as Xcode shows [by default, name is simply "iPhone", IIRC].

  • DavidSynottDavidSynott USMember ✭✭

    @NielsCup said:
    If your iPhone still does not show up: open iTunes while your phone is connected. It should ask you to connect to your phone. Allow it > select "trust computer" on your device > reconnect and your phone should be visible in Xamarin.

    Thank you! I have previously been using my iphone. Stopped developing a few weeks, came back and it was gone from the drop down. Opening itunes worked.

  • kisscoool18kisscoool18 Member ✭✭

    @DavidSynott said:

    @NielsCup said:
    If your iPhone still does not show up: open iTunes while your phone is connected. It should ask you to connect to your phone. Allow it > select "trust computer" on your device > reconnect and your phone should be visible in Xamarin.

    Thank you! I have previously been using my iphone. Stopped developing a few weeks, came back and it was gone from the drop down. Opening itunes worked.

    Exactly the same for me, thanks !

Sign In or Register to comment.