How can i downgrade compile version of my Xamarin.Android App?

Hi, everyone! Last few days i'm trying to compile my app under the target android version 7.0 (currently my app work only with android oreo 8.1). When i try to change compile version from 8.1 to 7.0 i get error that my mono version doesn't compatible with some nugets. And i don't know how to fix this. I've tried to manualy downgrade Xamarin.Forms nuget. This did not work. Then i tried manually delete all xamarin nuget (support v7, v4 e.t.c) and again download Xamarin.Forms with version compatible with mono v7. But nuget manager now can't resolve dependencies (used by compiler error). And so on, and so on... I am quite sure that i'm missing somthing simple, but important. How can i downgrade compile version from 8.1 to 7? Any help appreciated

Answers

  • BillyLiuBillyLiu Member, Xamarin Team Xamurai

    @Andrew121
    What's the error do you get?
    You could tried to clean your project and manually delete bin and obj folder, restart VS then rebuild your project.

Sign In or Register to comment.