Issues with uploading on iOS from WebView from Xamarin Forms

Hello, we are having an issue where we load a page with an input=file type form on it, we can click to select the file, the photo picker comes up and we can select an image (or take a new one with the camera) but then we just get a white screen. We've tried both with our web app that actually sends the file bytes up to the server as well as just a simple sample page that renders the result locally. The results are identical. From testing with the web app running locally we know our JS receives the callback from iOS but the bytes received are 0. We have tried using a custom renderer both for UIWebView and WKWebview as well as ensuring that the app has Camera, MediaLibrary and Photos permissions set correctly. It should be noted as well that the same page loaded in Safari on the same device works perfectly. We are at a total loss as all of the posts seem to assume this will just work on iOS (though there's a ton about issues and workarounds on Android).

Anyone run into similar issues or have any thoughts on troubleshooting this further?


  • ColeXColeX Member, Xamarin Team Xamurai

    If you can provide a basic sample, we are glad to help you for further troubleshooting .

Sign In or Register to comment.