"The iOS Designer Mac Agent is not available", but im connected to the mac machine

JCTJCT USMember

Hi there,

So im working on an ios app using Visual Studio 2015 in Windows connected by mac agent to the macincloud. Until now i havent had any problem, but today i just cant open storyboard. It give me an error like "The iOS Designer Mac Agent is not available. The iOS Designer requires an active connection to a Mac server. Please connect to a Mac to enable the designer.", but the weird thing is that i am connected to the mac machine and i can debug in the ios simulator without any problem. I leave here a screenshots so you can see the error and check than im connected to the machine.

I will appreciate any help.
Thank You.

Posts

  • FreddyQuirozFreddyQuiroz USMember

    I have the same problem. The log only say could not connect to remote mac: System.IO.EndOfStreamException: only read 0 of 4 bytes when the stream closed.
    I can debug in the ios simulator but cant open the IOs designer. Please help!

  • JCTJCT USMember
    edited July 2017

    This problem is finally solved! I leave here the solution for my problem, because this can help someone. All i had to do was delete Xamarin folder in ../UserName/AppData/Local/Temp.

  • FreddyQuirozFreddyQuiroz USMember

    The entire error message in the log:
    [2017-07-04 08:46:14.6] ERROR: Could not connect to the remote mac:
    System.IO.EndOfStreamException: Only read 0 of 4 bytes when the stream closed
    en MonoTouch.Design.RobustifiedStream.Read(Byte[] buffer, Int32 offset, Int32 count) en C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\Xamarin.Designer.iOS\MonoTouch.Design.Shared\RobustifiedStream.cs:línea 43
    en MonoTouch.Design.BinaryMessageFormatter.ReadInt32(Stream stream) en C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\Xamarin.Designer.iOS\MonoTouch.Design.Shared\Commands\BinaryMessageFormatter.cs:línea 108
    en MonoTouch.Design.BinaryMessageFormatter.Deserialize[T](RobustifiedStream stream) en C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\Xamarin.Designer.iOS\MonoTouch.Design.Shared\Commands\BinaryMessageFormatter.cs:línea 48
    en MonoTouch.Design.Client.RemoteDesignerAgentConnection.SendRequest(CommandRequest request) en C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\Xamarin.Designer.iOS\MonoTouch.Design.Client\Connection\RemoteDesignerAgentConnection.cs:línea 40
    en MonoTouch.Design.Client.RemoteDesignerAgentConnection.<>c__DisplayClass9_01.<SendRequestAsync>b__0() en C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\Xamarin.Designer.iOS\MonoTouch.Design.Client\Connection\RemoteDesignerAgentConnection.cs:línea 49 en System.Threading.Tasks.Task1.InnerInvoke()
    en System.Threading.Tasks.Task.Execute()
    --- Fin del seguimiento de la pila de la ubicación anterior donde se produjo la excepción ---
    en System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    en System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    en MonoTouch.Design.Client.RemoteDesignerAgent.d__16.MoveNext() en C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\Xamarin.Designer.iOS\MonoTouch.Design.Client\Connection\RemoteDesignerAgent.cs:línea 49
    --- Fin del seguimiento de la pila de la ubicación anterior donde se produjo la excepción ---
    en System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    en System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    en Xamarin.VisualStudio.IOS.Designer.MonoTouchDesignerPane.d__67.MoveNext() en C:\d\lanes\4699\fec6f88f\source\xamarinvs\src\Core\VisualStudio.IOS\Designer\MonoTouchDesignerPane.cs:línea 709

  • JCTJCT USMember

    @FreddyQuiroz My solution didnt help you? Have you already try it?

  • LanceKingLanceKing USMember ✭✭

    Having the same issue with VS2017 preview version. Mac agent connected, but storyboards give the error that the OP commented in the title. Tried your solution @JosCarlosTeixeira but that didn't work for me.

    Is this due to small version differences between X.iOS on windows (current preview version is 10.12.0.5) and the VS for Mac Beta channel? (Beta channel X.iOS version is 10.12.0.12)

  • FreddyQuirozFreddyQuiroz USMember

    I tried with no success.

  • If you are using a vm, only change the kind of network to bridge, I hope that worked for you

  • FreddyQuirozFreddyQuiroz USMember

    @JuanAlfredoBarraza said:
    If you are using a vm, only change the kind of network to bridge, I hope that worked for you

    Thank you very much

  • NguyenHoang.1174NguyenHoang.1174 USMember ✭✭

    @JosCarlosTeixeira said :
    This problem is finally solved! I leave here the solution for my problem, because this can help someone. All i had to do was delete Xamarin folder in ../UserName/AppData/Local/Temp.

    Thank you

  • F_OrtegaF_Ortega USMember

    @JuanAlfredoBarraza said:
    If you are using a vm, only change the kind of network to bridge, I hope that worked for you

    Can you explain a little more what do you do with change the kind of networking bridge???

  • @F_Ortega said:
    Can you explain a little more what do you do with change the kind of networking bridge???

    In my case, i worked with Virtualbox and configure it off this way:
    static.thegeekstuff.com/wp-content/uploads/2012/03/vb-cable-connected.png
    Check if there is a ping between the vm and your pc

  • SasanJamaliSasanJamali USMember ✭✭

    I tired help Me please!

  • SasanJamaliSasanJamali USMember ✭✭

    I tired help Me please!

  • SasanJamaliSasanJamali USMember ✭✭

    @NguyenHoang.1174 said:
    @JosCarlosTeixeira said :
    This problem is finally solved! I leave here the solution for my problem, because this can help someone. All i had to do was delete Xamarin folder in ../UserName/AppData/Local/Temp.

    Thank you

    Not worked

  • vinguanvinguan USMember ✭✭

    I was getting this error here. After i open the designer for the first time on the Mac within xCode and edited a storyboard or a xib file the designer on VS in Windows worked normally again.

  • KrisPetkovKrisPetkov BGMember ✭✭

    I faced the same issue. After closing and reopening the .xib file everything works fine

  • Deleting the temp folder didn't work for me. Nor was it a networking issue. For me I fixed it by installing an updated version of Visual Studio for Mac on my paired machine.

  • AviadKataniAviadKatani USMember ✭✭

    I'm experiencing the same issue, though the log file wrote:

    UNHANDLED EXCEPTIONS FROM PROCESS 49868:

    21/05/2018 18:37:06
    System.IO.IOException: Pipe is broken.
    at System.IO.Pipes.PipeStream.WinIOError(Int32 errorCode)
    at System.IO.Pipes.PipeStream.BeginWriteCore(Byte[] buffer, Int32 offset, Int32 count, AsyncCallback callback, Object state)
    at System.IO.Pipes.PipeStream.WriteCore(Byte[] buffer, Int32 offset, Int32 count)
    at System.IO.Pipes.PipeStream.Write(Byte[] buffer, Int32 offset, Int32 count)

    at Microsoft.Build.BackEnd.NodeEndpointOutOfProcBase.RunReadLoop(Stream localReadPipe, Stream localWritePipe, ConcurrentQueue`1 localPacketQueue, AutoResetEvent localPacketAvailable, AutoResetEvent localTerminatePacketPump)

    This is from the Temp folder.
    Tried to delete Xamarin from Temp... nothing works, I am connected to the Mac and Simulator is working, only storyboard not.

  • Have you tried installing latest visual studio for mac on the paired machine? Also update your vs2017 by looking at notifications.
  • KuraiKurai Member ✭✭

    For anyone who is still running in this error try updating Mono on the Mac. It did the trick for me.

  • allankallank Member

    This error is still available. In my case, i had the same error after updating my visual studio (on windows pc) some days ago.
    In my case, it was not the solution to delete the xamarin folder in local temp. With my network connection in my vm manager everything was fine, too. And at least i had update mono framework, but this was not enough and i still was not able to open the story board. At least i install visual studio on my mac vm ( i don´t had installed visual studio on the mac vm before, because i used visual studio on my windows pc), but after that the problem was solved and i can open the storyboard again.
    Puh, this visual studio update cost me some time and nerves ;)

Sign In or Register to comment.