Errors not showed in error list - build fails

FredyWengerFredyWenger CHInsider ✭✭✭✭✭

I work with a Xamarin.Forms project with VS2015 Update 3 RC and Xamarin-VS integration V
If there are errors, the build fails, the error window is not showed, the error count shows 0, in the output window, I can see the errors.
This is true, if I add a code line like "dgjweg"
If I do this in another ( project) with exactly the same VS2015 version, it works (the error list with the error is showed, I can click on an error an the source is loaded -> normal behavior.

So.. I think the problem is the .forms project and/or the Xamarin-VS integration SW.
I have wasted already a full day for searching the internet and try out any "solution" - nothing works.

Somebody can help me...?

You know about this problem (better: you have a solution for)?


  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Support added a bug in bugzilla, I added a video and a detailed description:

  • BlueRajaBlueRaja USMember ✭✭

    I had this exact issue. Turns out Xamarin was not referenced in one of my projects that had Xamarin Forms .xaml files, so the project silently failed at the "compiling XAML" step. Referencing Xamarin fixed the issue.

  • GurdeepGurdeep INMember ✭✭

    I was able to "solve" the problem...
    The problem was: Compiler don't stop, errors were only showed in the output window.
    -> This only for Xamarin projects (with VB.NET projects all has worked as expected)...
    To try find the reason for the problem, I have changed the Build Output in VS:

    • menu "Tools - Options"
    • from the left panel: "Projects And Solutions: Build And Run":
    • change "MSBuild Output Verbosity" from "Minimal" to "Diagnostic"

    After doing that, the compiler has stopped and the error was showed..
    After that, I have set the option back from "Diagnostic" to "Minimal" (like it was before) and... it has worked also with "Minimal" (to be sure, I also have restarted VS)...

    So.. it seems (at least im my case) that only to change (touch) the setting ("MSBuild Output Verbosity") has solved the problem and that this is a bug in VS and/or the Xamarin integration Software...

    it worked once but and next compile given the same problem.

Sign In or Register to comment.