iOS Remote simulator: Working but only show a black screen

Hi,

I connect Visual Studio to my MAC and works perfectly emulator on MAC if not check Remote Simulator to Windows option.

If I active that option, iPhone Emulator appears on my Window but only see a black screen on it.

If i open the emulator on Mac and simulator on Windows i can see that all is working because app runs perfectly and if y click on "windows simulator" the real emulator process all actions (clicks, buttons and keys): Its only a visual failure.

I tried reinstaling Visual Studio and formating Mac. Always the same result.

on logs \AppData\Local\Xamarin\Logs\Xamarin.Simulator, all is working fine:

Startup: arguments: --device=71A87D46-1657-48D6-A5E5-FF23A8FEABD5 --launchsim=//Users/iroot/Library/Caches/Xamarin/mtbs/builds/Arya.iOS/49b9eedddcd2865d1c5f249e9105532a/bin/iPhoneSimulator/Debug/AAAA.iOS.app -argument=-monodevelop-port -argument=59357 -setenv=__XAMARIN_DEBUG_PORT__=59357 --sdkroot=/Applications/Xcode.app -h=192.168.1.111 -ssh=iRoot --launched-by=devenv-15.0 version: 1.2.9.18 (4170120a1b2ae605aa66088327a09d707e02c407) Connection state changed: State: Connecting SSH Connect: target: 192.168.1.111:4231 Using SSH pass phrase SSH connected Connection state changed: State: Connected Connection state changed: State: CheckingServer Connection state changed: State: SettingUpServer Updating server Creating server directory: Path: /Users/iroot/Library/Caches/Xamarin/Simulator Uploading server: Remote Path: /Users/iroot/Library/Caches/Xamarin/Simulator/Xamarin.Simulator.Mac.zip Connection state changed: State: SettingUpServer Progress: 10% Connection state changed: State: SettingUpServer Progress: 20% Connection state changed: State: SettingUpServer Progress: 30% Connection state changed: State: SettingUpServer Progress: 40% Connection state changed: State: SettingUpServer Progress: 50% Connection state changed: State: SettingUpServer Progress: 60% Connection state changed: State: SettingUpServer Progress: 70% Connection state changed: State: SettingUpServer Progress: 80% Connection state changed: State: SettingUpServer Progress: 90% Connection state changed: State: SettingUpServer Progress: 100% Unzipping server: Path: /Users/iroot/Library/Caches/Xamarin/Simulator/Server Starting server [Server] Server ready. Connection state changed: State: Connecting Connection state changed: State: CheckingServer Connection state changed: State: Connected Start device request: Current State: Unknown UUID: 71A87D46-1657-48D6-A5E5-FF23A8FEABD5 Name: iPhone X Platform: iOS Version: 12.0 Device state changed: UUID: 71A87D46-1657-48D6-A5E5-FF23A8FEABD5 State: Starting Device state changed: UUID: 71A87D46-1657-48D6-A5E5-FF23A8FEABD5 State: Started SizeForScreen: Monitor: 0,0,1920,1040 Scale: 1,1 Source: 1125,2436 extraHeight: 84 Settings open: 5.676,886000ms

Someone can help me please? Thanks...

Answers

  • sadddsadsasadddsadsa USMember ✭✭

    up

  • PierceBogganPierceBoggan USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Could you please file an issue via Help > Send Feedback > Report a Problem? Once you have a link via that, feel free to post here so I can make the team aware. Thanks!

  • pavanlpavanl Member ✭✭

    Same problem here.. any idea? This is a known issue by now

    Log:

    Startup:
    arguments: --device=40F81D47-2433-4416-B9FB-311C780D2AED --launchsim=//Users/pavan/Library/Caches/Xamarin/mtbs/builds/abc.iOS/2c7f2ab57a68e33c2773924aa71e946e/bin/iPhoneSimulator/Debug/abc.iOS.app -argument=-monodevelop-port -argument=58287 -setenv=XAMARIN_DEBUG_PORT=58287 --sdkroot=/Applications/Xcode.app -h=iMac -ssh=abc --launched-by=devenv-15.0
    version: 1.3.0.8 (8ba0adc2af1ec7823507c0bf26dfe1daaed8f8f0)
    Connection state changed:
    State: Connecting
    SSH Connect:
    target: iMac:4231
    Using SSH pass phrase
    SSH connected
    Connection state changed:
    State: Connected
    Connection state changed:
    State: CheckingServer
    Connection state changed:
    State: Connecting
    Connection state changed:
    State: CheckingServer
    Connection state changed:
    State: Connected
    Start device request:
    Current State: Unknown
    UUID: 40F81D47-2433-4416-B9FB-311C780D2AED
    Name: iPhone 5s
    Platform: iOS
    Version: 12.1
    Device state changed:
    UUID: 40F81D47-2433-4416-B9FB-311C780D2AED
    State: Starting
    Device state changed:
    UUID: 40F81D47-2433-4416-B9FB-311C780D2AED
    State: Unknown
    Device state changed:
    UUID: 40F81D47-2433-4416-B9FB-311C780D2AED
    State: Starting
    Device state changed:
    UUID: 40F81D47-2433-4416-B9FB-311C780D2AED
    State: Unknown
    SizeForScreen:
    Monitor: 0,0,3840,2070
    Scale: 1,1
    Source: 640,1136
    extraHeight: 84
    Exit:
    Exit Code: 0
    Connection state changed:
    State: Disconnected
    Connection state changed:
    State: Disconnected

  • pavanlpavanl Member ✭✭

    @PierceBoggan said:
    Could you please file an issue via Help > Send Feedback > Report a Problem? Once you have a link via that, feel free to post here so I can make the team aware. Thanks!

    Is the team aware yet? Awake? :wink:

Sign In or Register to comment.