App store reject app upload with: CFBundleVersion Mismatch

mshwfmshwf EGMember ✭✭✭

I received a warning email from Apple hours after uploading the ipa, that:

CFBundleVersion Mismatch - The CFBundleVersion value '1' of extension 'MyApp.iOS.app/PlugIns/MyApp.Widget.appex' does not match the CFBundleVersion value '23.0' of its containing iOS application 'MyApp.iOS.app'.

CFBundleShortVersionString Mismatch - The CFBundleShortVersionString value '1.0' of extension 'MyApp.iOS.app/PlugIns/MyApp.Widget.appex' does not match the CFBundleShortVersionString value '23.0' of its containing iOS application 'MyApp.iOS.app'.

Despite they are both set to the same value:
Widget:

    <key>CFBundleVersion</key>
    <string>23.0</string>
<key>CFBundleShortVersionString</key>
<string>23.0</string>

Container App:

    <key>CFBundleVersion</key>
    <string>23.0</string>
   <key>CFBundleShortVersionString</key>
   <string>23.0</string>

each copied from its own plist.info file. Is something changing when I release the app?

Best Answer

Answers

Sign In or Register to comment.