Building iOS projects fails suddenly for all projects

On OSX I run into the issue that building any iOS project suddenly fails with an error while parsing a PList, presumably Info.plist:

System.ArgumentException: Failed to parse PList data type: ---> System.ArgumentException: Must specify valid information for parsing in the string. (Detailed diagnostic level stack trace see below.)

This includes freshly created Xamarin template projects without any changes to them, so the error is not project specific but seems to be related to my installation/environment. The only change I am aware of which somehow could have triggered this issue was changing the Command Line Tool location in Xcode because I needed to use the Xcode 7 tool set for one of my Xcode projects (I have Xcode 8 and 7 installed in parallel). However I switched back to the Xcode 8 location and checking the command line tools with xcode-select -p yields the expected result (Xcode 8 installation path).

I poked at this for a while without success and I already tried reinstalling Xamarin Studio without success. And I would really prefer not to go through the whole ordeal of uninstalling and reinstalling Xcode etc. just to find out if that maybe solves the issue. This is really a bummer because I can currently not build ANY iOS projects on my machine.

Is there a way to get more diagnostic information, e.g. which file exactly does not get parsed and which parameter it doesn't like? Is this due to a mixup of the tools that are used (Xcode 7 vs Xcode 8)? I also attached the Xamarin Studio details at the end. Note that according to that information Xcode 8 is used, as expected.

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Error executing task CompileAppManifest: Failed to parse PList data type: Error executing task CompileAppManifest: System.ArgumentException: Failed to parse PList data type: ---> System.ArgumentException: Must specify valid information for parsing in the string. at System.Enum+EnumResult.SetFailure (System.Enum+ParseFailureKind failure, System.String failureMessageID, System.Object failureMessageFormatArgument) [0x00026] in <dca3b561b8ad4f9fb10141d81b39ff45>:0 at System.Enum.TryParseEnum (System.Type enumType, System.String value, System.Boolean ignoreCase, System.Enum+EnumResult& parseResult) [0x00086] in <dca3b561b8ad4f9fb10141d81b39ff45>:0 at System.Enum.Parse (System.Type enumType, System.String value, System.Boolean ignoreCase) [0x00010] in <dca3b561b8ad4f9fb10141d81b39ff45>:0 at System.Enum.Parse (System.Type enumType, System.String value) [0x00000] in <dca3b561b8ad4f9fb10141d81b39ff45>:0 at Xamarin.MacDev.PropertyListFormat+XmlFormat+Context.ReadObjectHead () [0x00018] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 --- End of inner exception stack trace --- at Xamarin.MacDev.PropertyListFormat+XmlFormat+Context.ReadObjectHead () [0x0004a] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.MacDev.PropertyListFormat+XmlFormat+Context..ctor (System.Xml.XmlReader reader) [0x0000e] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.MacDev.PropertyListFormat+XmlFormat.StartReading (System.IO.Stream input) [0x0008d] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.MacDev.PropertyListFormat.CreateReadContext (System.IO.Stream input) [0x00013] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.MacDev.PDictionary.FromFile (System.String fileName, System.Boolean& isBinary) [0x00025] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.MacDev.PDictionary.FromFile (System.String fileName) [0x00001] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.MacDev.AppleSdk.GetDTSettings () [0x00028] in <9cedd7428f9c45a4a1b79446d441d7cf>:0 at Xamarin.iOS.Tasks.CompileAppManifestTaskBase.Compile (Xamarin.MacDev.PDictionary plist) [0x000dc] in <944691a919ba4fa790d9a12b1a7fbb8b>:0 at Xamarin.iOS.Tasks.CompileAppManifestTaskBase.Execute () [0x0027d] in <944691a919ba4fa790d9a12b1a7fbb8b>:0 at Microsoft.Build.BuildEngine.TaskEngine.Execute () [0x00000] in <29ed228a0f8e4d039e4eda81cff6d54b>:0 at Microsoft.Build.BuildEngine.BuildTask.Execute () [0x0008f] in <29ed228a0f8e4d039e4eda81cff6d54b>:0 Done building target "_CompileAppManifest" in project "/Users/nussberger/Projects/testios/testios/testios.csproj" ("/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets"); "_CreateAppBundle" depends on it. Done building target "_CreateAppBundle" in project "/Users/nussberger/Projects/testios/testios/testios.csproj" ("/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets"); "Build" depends on it. Done building target "Build" in project "/Users/nussberger/Projects/testios/testios/testios.csproj" ("/Library/Frameworks/Mono.framework/Versions/4.6.1/lib/mono/xbuild/14.0/bin/Microsoft.Common.targets").

=== Xamarin Studio Community ===

Version 6.1.1 (build 15)
Installation UUID: 20a2b994-e473-40c8-92cd-6bea57245232
Runtime:
Mono 4.6.1 (mono-4.6.0-branch-c8sr0/ef43c15) (64-bit)
GTK+ 2.24.23 (Raleigh theme)
Package version: 406010005

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 7.0.1.3 (Xamarin Studio Community)
Android SDK: /Users/nussberger/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
4.0.3 (API level 15)
4.4 (API level 19)
5.1 (API level 22)
6.0 (API level 23)
7.0 (API level 24)

SDK Tools Version: 25.2.2
SDK Platform Tools Version: 24.0.3
SDK Build Tools Version: 24.0.3

Java SDK: /usr
java version "1.8.0_74"
Java(TM) SE Runtime Environment (build 1.8.0_74-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.74-b02, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 8.0 (11246)
Build 8A218a

=== Xamarin.iOS ===

Version: 10.0.1.10 (Xamarin Studio Community)
Hash: ad1cd42
Branch: cycle8-sr0-xi
Build date: 2016-10-03 15:18:44-0400

=== Xamarin.Mac ===

Version: 2.10.0.105 (Xamarin Studio Community)

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:03:02-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.11.6
Darwin Florians-MBP 15.6.0 Darwin Kernel Version 15.6.0
Mon Aug 29 20:21:34 PDT 2016
root:xnu-3248.60.11~1/RELEASE_X86_64 x86_64

Best Answer

Answers

  • rseostarrseostar USUniversity ✭✭

    Running into the same issue and my machine has never had Xcode 7 on it, so I don't think that is related to this particular issue.

  • MatthewWaring.4722MatthewWaring.4722 GBUniversity ✭✭

    Hey! I have just had this pain when installing XCode 9.3 on my mac! I had noticed a similar pain point on one of my laptops with a different error than the PLIST one.

    And I can say that I think reinstalling the command line tools "AGAIN" (xcode told me they had updated but ..) sorted the issue out.

    You can use -

    xcode-select --install

    Hope this helps

  • Don't forget to launch xcode at least one time after it's update.... :smiley:

  • ThomasLambThomasLamb USUniversity ✭✭

    MatthewWaring.4722

    Where do you enter xcode-select --install? I'm getting this error now. I've rolled back to XCode 9.2, and I'm running it on the mac. I use Visual Studio Windows to do my work on, connected to the Mac.

  • IrgiIrgi USMember ✭✭

    @JonathanANTOINE said:
    Don't forget to launch xcode at least one time after it's update.... :smiley:

    Thanks a lot, that fixed it in my case!

  • @JonathanANTOINE
    Thanks for the tip. That solved the issue for me

Sign In or Register to comment.