I need Visual Studio 2017 older(15.4.0) version.

Hi.

I have been developing xamarin app using Microsoft Visual Studio 2017(15.8.5).
It was success in android build but I have encountered problems in ios build.
I tried to simulate ios version by Remote Connect with Mac but visual studio returned errors.
Because of the version of xCode(9.2) is lower than required(9.4).
I am using Mac system on non-apple computer and it is difficult to upgrade xCode version.
The way to solve it is to install Visual Studio 2017 earlier version compatible with my xCode Version.
But i could not find the download link to do it.
I have seen many articles for this but it redirected to the latest version.
Please help me in this.
I am sorry for my little English.

Thanks

Answers

  • Ahsan_SiddiqueAhsan_Siddique PKMember ✭✭✭✭

    @AtabaevR said:
    Hi.

    I have been developing xamarin app using Microsoft Visual Studio 2017(15.8.5).
    It was success in android build but I have encountered problems in ios build.
    I tried to simulate ios version by Remote Connect with Mac but visual studio returned errors.
    Because of the version of xCode(9.2) is lower than required(9.4).
    I am using Mac system on non-apple computer and it is difficult to upgrade xCode version.
    The way to solve it is to install Visual Studio 2017 earlier version compatible with my xCode Version.
    But i could not find the download link to do it.
    I have seen many articles for this but it redirected to the latest version.
    Please help me in this.
    I am sorry for my little English.

    Thanks

    You can download from this site.

    https://developer.xamarin.com/releases/

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @AtabaevR

    I am using Mac system on non-apple computer and it is difficult to upgrade xCode version.

    This is not a supported scenario. According to Apple's licensing you need a real Mac to develop iOS apps, so the correct answer to this issue is to get a Mac and get the latest XCode.

    The way to solve it is to install Visual Studio 2017 earlier version compatible with my xCode Version.
    But i could not find the download link to do it.

    Only the last couple of releases of Visual Studio are publicly available here: https://docs.microsoft.com/en-us/visualstudio/productinfo/installing-an-earlier-release-of-vs2017#installing-the-earlier-release

Sign In or Register to comment.