why all rda.socket pcl package files are not installed in project

Arjun1Arjun1 ✭✭Member ✭✭
edited September 2018 in Cross Platform with Xamarin

Hi everyone..
I'm trying use rda.socket pcl package in my project but it not installing properly.im using vs2017

and the error in project is

Answers

  • ClintStLaurentClintStLaurent ✭✭✭✭✭ USUniversity ✭✭✭✭✭

    What does the warning say when you hover mouse over the yellow alert symbol?

  • Arjun1Arjun1 ✭✭ Member ✭✭

    Warning NU1701 Package 'Sharpcaster.SocketsForPCL 2.0.4' was restored using '.NETFramework,Version=v4.6.1' instead of the project target framework '.NETStandard,Version=v2.0'. This package may not be fully compatible with your project. SMT400

  • ClintStLaurentClintStLaurent ✭✭✭✭✭ USUniversity ✭✭✭✭✭

    So... Now that you've read it... Do you see that it's not a case of it not installing correctly?

    It just wasn't made specifically for .NET standard and so may not work as expected. Use it. See if it does what you need. Not all packages have to have a specific implementation for it if they don't need it.

  • Arjun1Arjun1 ✭✭ Member ✭✭

    Thanks for reply ..
    but i wan to use socket plugin for .net standard ssuggest best one im new to xamatin forms

Sign In or Register to comment.