Could not load assembly Xamarin.iOS in an Android project

brickybricky DKMember ✭✭

I have an Android project and all of a sudden I started receiving the following exception:
Severity Code Description Project File Line Suppression State
Error Exception while loading assemblies: System.IO.FileNotFoundException: Could not load assembly 'Xamarin.iOS, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065'. Perhaps it doesn't exist in the Mono for Android profile?
File name: 'Xamarin.iOS.dll'
at Xamarin.Android.Tuner.DirectoryAssemblyResolver.Resolve(AssemblyNameReference reference, ReaderParameters parameters)
at Xamarin.Android.Tasks.ResolveAssemblies.AddAssemblyReferences(ICollection`1 assemblies, AssemblyDefinition assembly, Boolean topLevel)
at Xamarin.Android.Tasks.ResolveAssemblies.Execute() ShellAndroid

Does somebody have a clue how to solve this?

Answers

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    First check that you don't actually reference it. When does it happen?

  • brickybricky DKMember ✭✭

    I do not reference it. My project started failing when I tried including the Xamarin.Plugin in it. I tried cleaning and rebuilding multiple times, then I created a new project, did not reference the plugin in any of the listed. Tried looking if I am referencing it somewhere, which I cannot seem to find. I spent three days on trying to find this and nothing has helped so far.

  • brickybricky DKMember ✭✭

    Turned out that there was a GoogleMaps reference which was targeting iOS.

  • SheemuSheemu USMember ✭✭✭

    Hi @bricky, have you found any answer for it so please tell me.

    Thanks in Advance.

  • deczalothdeczaloth DEMember ✭✭✭
    edited September 2018

    @Sheemu said:
    Hi @bricky, have you found any answer for it so please tell me.

    @Sheemu , see @bricky comment just above yours.

    I had the same problem. In my case it turned out that somehow the Android project had added references to my iOS project. Removing that reference was the solution in my case.

  • SheemuSheemu USMember ✭✭✭

    ya @deczaloth, same I had resolved before a few months ago but sometimes I do face this issue but now I am not worry about it :smile:

Sign In or Register to comment.