Ton of intellisense issues /w VS2013, Latest Stable Release, & Resharper

I've been having a ton of intellisense issues with the latest release. PCL libraries almost entirely get marked as "Missing System.Runtime v4...". Other project types only mark my class types as unknown. Everything compiles though. I believe the problem is between resharper & xamarin somehow as everything returns to normal if I remove one of them. I've tried cleaning out all of the resharper and VS cache folders and that did not help.

Has anyone had similar issues and perhaps a workaround?

Posts

  • AndreKohnAndreKohn DEMember

    I guess my post targets exactly the same issue. As I'm not using Resharper I would guess its the PCL itself or BCL (do you reference any BCL NuGet Lib?). Blend is by the way working just fine which should be a workaround until that gets fixed.

  • AllanRitchie-oldAllanRitchie-old CAInsider ✭✭✭

    I did have the BCL package which I have removed. It doesn't appear to have helped. PCL's just suffer the worst of the intellisense issues. Normal libraries are also having the issue, just not to the same extent.

  • I guess there are several issues with Visual Studio 2013 and Xamarin.
    As I installed Xamarin, Intellisense was gone completely in a Web project which has nothing to do with mobile development. There is also an error with the settings page of Xamarin Tools=>Options=>Xamarin.
    At the beginning I thought it is because of another component. I took the time and removed the other component and Xamarin. Then Intellisense was working. After reinstalling Xamarin, Intellisense was gone.
    Part time workaround: start Visual Studio from the commandline with /safemode. (This disables all plugins)

  • MihaMarkicMihaMarkic SI ✭✭✭✭
    edited November 2013

    I pinpointed this issue to Xamarin and existence of .suo files. Try deleting .suo file and it will probably open just fine. Until you close VS (which recreates .suo) and reopen the project. Highly annoying.

  • AllanRitchie-oldAllanRitchie-old CAInsider ✭✭✭

    Deleting the suo files worked for me. Thanks!

  • Indeed intellisense/code completion in VS2013 stops working after installing Xamarion.IOS and/or Xamarin.Android. After unistalling intellisense is back. No Resharper installed on that machine. It happens with VS2013 Premium and on a machine with VS2013 Prof.
    This should not happen with software in the stable line!
    Also creating a PCL in VS2013 gives an error about different ToolsVersion when opening the project in Xamarin Studio.

  • Ok. I'm glad MihaMarkic helped me on twitter to find this thread. Xamarin is uninstalled now, and I hope to get notified here when a fix has been provided so I can install it again.

  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    Have any of you filed a report at http://bugzilla.xamarin.com so the dev team is aware of the issue?

  • RossDargan.0957RossDargan.0957 GBInsider, University ✭✭

    Apparently this bug: https://bugzilla.xamarin.com/show_bug.cgi?id=13274 covers the issue - but it looks like its internally visible only. I have been re-assured that it's getting fixed.

  • This is very annoying indeed, does anyone know if there are any problems on the ReSharper side of the fence?

    Should we notify JetBrains as well?

  • GeirSagbergGeirSagberg NOMember

    I have notified JetBrains, there is a ticket here: http://youtrack.jetbrains.com/issue/RSRP-394695

  • I hope this get fixed soon, because its a pain to run in safemode. Any update when this will be fixed?

  • For me at least, simply unloading and reloading the affected projects temporarily fixes this (until VS is restarted again). I get to keep Resharper around.

  • I got a response from Xamarin support just now, apparently they think they've found the bug and have a fix.

    Hopefully we'll get a new release soon:)

  • MattSpradleyMattSpradley USMember ✭✭

    As Morten Aune Lyrstad indicated, unloading are reloading the project works for me as well. I also had problems with the XAML designer for Windows Phone complaining about invalid markup until I unloaded and reloaded the Windows Phone project.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    I have been deleting the suo file ever time until the fix comes out. Works like a charm.

  • SpartanSpartan USMember

    I'm using PCL and I have also observed intellisense issues (highlighted in red in code) in VS2013.

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    I'm using PCL and I have also observed intellisense issues (highlighted in red in code) in VS2013.

    Did you try deleting sou file before you open the solution or reload the project?

  • rishi.9970rishi.9970 USMember

    Where is the suo file? >_>

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    @rishi.9970 it is right next to the .sln file, it is hidden though so you will need to show hidden files.

    It is usually called .v12.suo

  • With the latest alpha, this problem is even worse:/
    Deleting the suo-file no longer works as a workaround, essentially rendering Visual Studio unusable for me.

  • MattSpradleyMattSpradley USMember ✭✭

    Oystein, does unloading and reloading the project work? It does for me.

  • EmmanuelHunaEmmanuelHuna USUniversity ✭✭

    Same issue here with the latest Xamarin tools as of 12/27/2013 and the latest Resharper, v8.1.

    Tools > options > Resharper > General > Pause Resharper fixes the issue.

    Re-enabling Resharper and unloading the reloading each project in my solution also fixes the problem.

  • Unloading and then reloading the project worked for me

  • softlionsoftlion FRBeta ✭✭✭
    edited January 2014

    +1.

    There are some solutions on the jetbrain thread: http://youtrack.jetbrains.com/issue/RSRP-394695

  • AllanRitchie-oldAllanRitchie-old CAInsider ✭✭✭

    It seemed that 4.10 fixed this issue, however, with 4.12, it is back with a vengeance. Even with the suo being deleted, it doesn't seem to help any longer. Anyone else experiencing this again?

  • CarlPerkinsCarlPerkins USMember

    Unloading and then reloading the project worked for me also - THANKS for the tip; I was going back to VS 2012 but now I can use 2013 with its great new features.

  • ErosSteinErosStein BRMember

    Here's my 2p: after struggling a lot with this problem I found out that unloading and reloading the WP project fixed the issue. Not sure you're working with WP here, but for me was just that project... unload WP project, reload it and everything is peachy! =/ it's my new work routine...

  • JamesGreen.8031JamesGreen.8031 GBMember ✭✭

    I#m running ReSharper 9.1.1 and to be honest I've seen this version get "stuck" with "old" errors and inspection reports more than any other previous version of ReSharper. It's like it gets stuck with an old Cache of problems.

Sign In or Register to comment.