Forum Visual Studio

Unity 2018 + Visual Studio for Mac underlining everything

After upgrading to Unity 2018.1.7 I started using Visual Studio for Mac 7.5.3. My code is all underlined with errors like "predefined type System.Void is not defined or imported", I think it never worked properly.

Unfortunately the forum doesn't allow me to post an image, but basically any references to types and classes are underlined, along with methods and etc.

I tried deleting the solution and related files and the VS cache under ~/Library/Caches but it didn't work. I also disabled Source Analysis but it keeps underlining everything.

How can I fix this?


  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai


    Would you please report this from Visual Studio for Mac via the Help > Report a Problem menu? That will let you file this on developer community and attach images and logs. We'll be able to better track it there. Feel free to tag me (@JohnMiller) with a link to the post when you get it submitted - I will take a look.

  • roberto_scroberto_sc NZMember

    Hi @JohnMiller
    I reported a problem like you advised back in July but so far I didn't hear anything from them.
    I've been using VS in different projects with that problem since then. It's been a major hassle, I'm almost giving up on it because it's too counter-productive.
    Can you please take a look at it?
    Thank you.

Sign In or Register to comment.