Forum Xamarin.Android

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Xamarin Android app state not saved on deployment

Hi,

When I deploy the project to a phone, the app's state is not saved, ie anything I did previously, like saving login details, is lost. I have tried this on multiple phones and Android versions. This is an issue specific to my development environment, because on another computer with the same project the issue is not there.

I tried searching on Google but I couldn't find much information on this at all. Can somebody point me in the right direction for how I might fix this?

Thanks!

Tagged:

Best Answer

  • BillyLiuBillyLiu Member, Xamarin Team Xamurai
    Accepted Answer

    @wellhat
    What do you mean app's state is not saved? Do you mean your app's data/cache get cleaned every deploy?
    I think you could go to Tools->Options->Xamarin->Android Settings and enable Preserve application data cache on device between deploys.

Answers

  • BillyLiuBillyLiu Member, Xamarin Team Xamurai
    Accepted Answer

    @wellhat
    What do you mean app's state is not saved? Do you mean your app's data/cache get cleaned every deploy?
    I think you could go to Tools->Options->Xamarin->Android Settings and enable Preserve application data cache on device between deploys.

  • wellhatwellhat Member ✭✭

    Thanks! I did indeed mean that my data/cache was wiped each time I deploy. No idea how that setting got disabled, but that solved the problem.

  • wellhatwellhat Member ✭✭

    Thanks! I did indeed mean that my data/cache was wiped each time I deploy. No idea how that setting got disabled, but that solved the problem.

Sign In or Register to comment.