Xamarin Studio - Consider disabling the ENABLE_ON_DEMAND_RESOURCES build setting -- how?

I added some image resources to a simple Xamarin Forms test project. in Xamarin Studio on macOS. Now I am getting this error:

Error: Cannot enable on demand resources for the platform "iOS Simulator" when targeting releases prior to 9.0. Consider disabling the ENABLE_ON_DEMAND_RESOURCES build setting.

I see in the settings how to configure some values for on-deman resources, but no way to disable the setting entirely. How is this done in Xamarin Studio?

Answers

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    Xamarin Studio is approaching end of life - replaced by Visual Studio even on the Mac.
    I doubt it will see much in the way of updates .

  • DavidShawDavidShaw USMember ✭✭

    I thought Visual Studio on mac was just in an early preview. Are people actively using it for production work on a Mac now?

  • > @DavidShaw said:
    > I added some image resources to a simple Xamarin Forms test project. in Xamarin Studio on macOS. Now I am getting this error:
    >
    > Error: Cannot enable on demand resources for the platform "iOS Simulator" when targeting releases prior to 9.0. Consider disabling the ENABLE_ON_DEMAND_RESOURCES build setting.
    >
    > I see in the settings how to configure some values for on-deman resources, but no way to disable the setting entirely. How is this done in Xamarin Studio?

    May have to bump minimum build target to 9.0 or check Contents.json of imageset and remove on demand property.
  • LaobuLaobu USMember ✭✭

    Well, I had a similar problem when in Assets.xcassets I filled in the 'ON-Demand Resource Tags' for an image. I thought first this was the reference name for the image to be used in the code but, it isn't. Instead, the name to be used is in the left column in fact under AppIcon. There you can rename it to waterever you want.

    So, leaving ''ON-Demand Resource Tags' empty removed any compile problems and I was able to use the image in the code with a with 'UIImage.FromBundle(imageName);'

  • MohammedAjroudiMohammedAjroudi USMember ✭✭

    @Laobu Thanks it solved it for me :)

Sign In or Register to comment.