Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

How to target Xamarin.Mac Full framework after vsmac update

starl1nstarl1n DOUniversity ✭✭
edited August 2018 in Xamarin.iOS

Hi everyone,

I have been facing issues since latest update of VSMac , I have a project Xamarin.Mac that target Xamarin.Mac Full .Net Framework 4.5, but since the update i got so many errors on everywhere (iOS, android, mac, forms) I decided to remove everything (using the bash script) and re-install from scratch, all the other projects got "solved" but

Now i can't select the target framework Xamarin.Mac Full, i'm guessing that i don't have the .NET Framework 4.5 installed , got error of mismatch of dependent assembly, some other issues with mcs.exe file

Does anyone have a hint for this ?
Thank you


Best Answer

  • starl1nstarl1n DOUniversity ✭✭
    Accepted Answer

    Apparently using previous version of Mono fix the issue , this build from April fix the problem

Answers

  • starl1nstarl1n DOUniversity ✭✭
    Accepted Answer

    Apparently using previous version of Mono fix the issue , this build from April fix the problem

  • ChrisHamonsChrisHamons USForum Administrator, Xamarin Team Xamurai

    That seems very strange, why is it wanting to use mcs instead of csc?

    Could you attack your project \ build log possibly?

Sign In or Register to comment.