Visual Studio 2017 v15.8.0 Android Emulator with Hyper-V problem

AlbertKAlbertK MYMember ✭✭✭

I just update Visual Studio 2017 to version 15.8.0, the one that I've been waiting for a while now, due to its support for Hyper-V accelerated Android emulators using Windows Hypervisor Platform (WHPX).

I've been running Windows 10 version 1803 since June, and I have Windows Hypervisor Platform enabled . Also, I have updated Android SDK (27.2.7) and tools as it's described in https://docs.microsoft.com/en-us/xamarin/android/get-started/installation/android-emulator/hardware-acceleration.

However, when I run any of the X86 accelerated emulators, I get an error:

We've encountered an error with your Windows Hypervisor Platform (WHPX) configuration that is preventing us from running your emulator accelerated.

Please ensure WHPX is properly installed, then perform a factory reset on the emulator and try again.

No log and nothing else. Hence, I'm a bit confused and don't know what I should do next.

Appreciate any help.

Best Answers

Answers

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @AlbertK

    I have found that I need to recreate my emulators from scratch after switching from HAXM to Hyper-V emulators.

    Might also want to uninstall HAXM (Intel Hardware Accelerated Execution Manager) and reboot. You can uninstall it from the Apps and Features page (search for Add or Remove Programs).

  • AlbertKAlbertK MYMember ✭✭✭

    @JGoldberger said:
    @AlbertK

    I have found that I need to recreate my emulators from scratch after switching from HAXM to Hyper-V emulators.

    Might also want to uninstall HAXM (Intel Hardware Accelerated Execution Manager) and reboot. You can uninstall it from the Apps and Features page (search for Add or Remove Programs).

    I have removed HAXM long time ago and even check the regedit and there is no trace of HAXM in the system. FYI, I have Hyper-V running (one Ubuntu VM and Docker MobyLinuxVM). What else can I do? Thank you.

  • AlbertKAlbertK MYMember ✭✭✭

    Ticking on the "Windows Hypervisor Platform" did the trick. Please make this sticky. Thank you.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Glad it worked. I don't think this thread needs to be sticky as this is indicated in the very document you linked:
    https://docs.microsoft.com/en-us/xamarin/android/get-started/installation/android-emulator/hardware-acceleration?tabs=vswin#hyper-v

    Step 2:

    1. Enable the Windows Hypervisor Platform. In the Cortana Search bar, type Turn Windows features on or off. Scroll down in the Windows Features dialog and ensure that Windows Hypervisor Platform is enabled:
  • AlbertKAlbertK MYMember ✭✭✭

    @JGoldberger said:
    Glad it worked. I don't think this thread needs to be sticky as this is indicated in the very document you linked:
    https://docs.microsoft.com/en-us/xamarin/android/get-started/installation/android-emulator/hardware-acceleration?tabs=vswin#hyper-v

    Step 2:

    1. Enable the Windows Hypervisor Platform. In the Cortana Search bar, type Turn Windows features on or off. Scroll down in the Windows Features dialog and ensure that Windows Hypervisor Platform is enabled:

    I am pretty sure, I did not see the Windows Hypervisor Platform option before rebooting the machine. Would we evey see the ARM based Emulator get accelerated via the Hypervisor ? Thank you.

Sign In or Register to comment.