Unable to run project with UWP and NetStandard after Vs 2017 upgrade

venkatkvenkatk USMember ✭✭

Hi Team,

I am unable to build my UWP project after migrating from VS2015 to VS 2017 i am getting the below build errors:
Severity Code Description Project File Line Suppression State
Error CS0012 The type 'Attribute' is defined in an assembly that is not referenced. You must add a reference to assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51'.

Although i have added NetStandard.Library to the project but unable to build the solutions.

I have added reference for netStandard and also changed to Windows Fall creator in UWP Project properties -> application.

2.0.3

Can you please suggest me how to resolve this issue?

Thanks
Venkat

Answers

  • kentuckerkentucker USMember ✭✭✭✭✭

    To use .net standard 2.0 in UWP you need to make sure the minimum version of windows 10 supported for the UWP app is the fall creators update 16299

  • venkatkvenkatk USMember ✭✭

    @Kentucker: I Have changed the same in UWP properties,but still no luck

  • ViikkiViikki USMember ✭✭

    For me it works after elevating minimum version.

Sign In or Register to comment.