WebPage not Available displaying on Android WebVIew

MuhiMuhi Member ✭✭

I have a simple webView that calls a loginURl. after the redirect I'm getting a webpage not Available for the return URL from redirect.
How can I catch this and not display the Webpage not available? This works ok on IOS..
This is the XAML code that I have set up for my webview in my contentPage

<WebView  x:Name="loginWebView"   
                    Source="{Binding LoginUrl}"
                    AbsoluteLayout.LayoutBounds="0, 0, 1, 1"
                    AbsoluteLayout.LayoutFlags="All">
                <WebView.Behaviors>
                    <behaviors:EventToCommandBehavior 
                            EventName="Navigating"
                            EventArgsConverter="{StaticResource WebNavigatingEventArgsConverter}"
                            Command="{Binding NavigateCommand}" />
                </WebView.Behaviors>
</WebView>

Answers

  • robbitrobbit CNMember Xamurai

    What is your LoginUrl, can I try it?

  • MuhiMuhi Member ✭✭

    @robbit
    No I am not able to give any detail its just an OAuth2 end point ..

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @Muhi

    I was not able to reproduce this issue.

    Not sure why you are using a converter for the event args. Did you need to change the WebNavigatingEventArgs type to some other type? I suspect the issue may lie there. Try not using the converter. Or if you need it, include more context for your code, i.e. the full XAML page with resources and the converter class and view model would be helpful.

Sign In or Register to comment.