Which version of Xamarin.Forms is for which Android api? (In particular 5.1 Lollipop)

Which version of Xamarin.Forms is for which Android api? (In particular 5.1 Lollipop)
It seems like there should be a wiki chart for this?

Answers

  • SzbestaSzbesta Member ✭✭✭

    @meonwin7_64 As far as i know the last supported android API is Android 4.0.3 (API 15) taken from here https://docs.microsoft.com/en-us/xamarin/xamarin-forms/get-started/installation?tabs=vswin#android

  • meonwin7_64meonwin7_64 Member ✭✭

    @Szbesta Thank you for your reply.

    I was asking specifically about the Xamarin.Forms version...Currently the max is 3.1.0.637273 while android is ver 8 ?
    Soooo, do I adjust the Xamarin.Forms version to be a ver approx 2.x ??? Someone recommended keeping Xamarin.Android at 22.x (instead of the 27.x max---these versions track obviosly with the api)

    Also, from the page you reference, I need to set a "Target SDK of 7 or 8" for compile and that apk would still work for 5.1 ??

    "Additionally, the target/compile version for Android projects must be set to Use latest installed platform. However the minimum version can be set to API 15 so you can continue to support devices that use Android 4.0.3 and newer. These values are set in the Project Options:"

  • SzbestaSzbesta Member ✭✭✭
    edited July 2018

    I think you can use any Forms version. I am still using Xam.Forms 2.5 as I'm having difficulties updating to 3.x.
    As you have quoted in your answer:

    "Additionally, the target/compile version for Android projects must be set to Use latest installed platform. However the minimum version can be set to API 15 so you can continue to support devices that use Android 4.0.3 and newer. These values are set in the Project Options:"

    Yes it will still work for 5.1 if you set it as it is mentioned.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @Szbesta Is correct. There is no correlation between versions of Xamarin.Forms and platform versions. You don't need a given Xamarin.Forms version to correspond with Android version XX or iOS version YY.

    Just update everything and run with scissors - you'll be fine.

Sign In or Register to comment.