Java heap space OutOfMemoryError when binding a big .jar

2»

Posts

  • mnayyermnayyer ✭✭ PKMember ✭✭
    edited May 2017

    @JonathanPryor @JenniferRostenne

    Neither

    1G

    nor
    _JAVA_OPTIONS environment variable with value -Xmx1g helped me...

    please help.

  • MahibaRajaseelanMahibaRajaseelan ✭✭ USMember ✭✭

    Its working for me.
    In Visual Studio, settings available in Properties - > Android Options -> Advanced -> Advanced Properties -> Java Max Heap Size. Set it to 1G.

  • SKSSKS USMember
    edited November 2017

    Setting up Java Max Heap Size to 1G in ProjectName.Android-->Advanced Android Options worked for me

  • onraltnonraltn Member

    @arslanan resolved this problem. After the latest update of Xamarin, you should delete JAVA from Environment Variables.
    Steps:

    This pc -> Properties -> Advanced System Settings ->Environment Variables -> (you will see java below system variables).

  • FelipeSouzaLongoFelipeSouzaLongo ✭✭ USMember ✭✭

    Using Visual Studio

    Thanks!!
    Using the Visual Studio Project Properties i set the size to 1G (1 Gigabyte) and it worked like a charm.

  • DeepakDYDeepakDY ✭✭✭ INMember ✭✭✭

    I changed heap size(1G) in android property and it's worked for me

Sign In or Register to comment.