System.TypeLoadException when launching android project

pacomaralpacomaral Member ✭✭
edited July 2018 in Xamarin.Forms

Hello.

I recently made some changes in my Xamarin.Forms project to release an APK (I've been testing on a device in debug mode), and now I'm not able to debug on a device like I've been doing all the time.

I'm getting this exception when the app launches and I don't know what to do. I read a lot of discussions about this exception and I've tried to delete obj/bin folders, rebuild, restart VS, check if my xamarin.forms has the same version on all the projects, tried all the options of linking in my android project...

Unhandled Exception:

System.TypeLoadException: Could not resolve type with token 01000027 (from typeref, class/assembly Gexplore.App, Gexplore, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)

It says that the problem comes from my App class but I haven't changed nothing on there.

Someone has any idea of how could I fix this problem?

Posts

  • robbitrobbit CNMember Xamurai

    Hi @pacomaral

    Please read this to get more detail logs:

  • pacomaralpacomaral Member ✭✭
    edited July 2018

    Hello @robbit. I did that but I can't see nothing interesting between the input code. What should I expect to find in there?

    The only thing i've found is this:

    `Found conflicts between different versions of the same dependent assembly that could not be resolved. These reference conflicts are listed in the build log when log verbosity is set to detailed. `
    

    Anyway, I couldn't find that conflicts in the output build even having the mode on Diagnostic.

    Any ideas?

Sign In or Register to comment.