Forum Visual Studio


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Version control operation failed: . https://.git: not authorized

GenCode_OLDGenCode_OLD USMember
edited March 2013 in Visual Studio

First time I connected to my repository I was asked to enter a password.
I entered it wrong.

Issue is it is no longer asking me for my password, it immediately gives me this message
Version control operation failed: . https://[email protected]: not authorized

I changed the username to random and it asked for my passowrd, put it back to my real username and again I get
Version control operation failed: . https://[email protected]: not authorized

with no chance to enter my password.

Apparently somewhere on my mac the wrong pwd is stored?

How do I clear it?

Thanks, GenCode


  • GenCode_OLDGenCode_OLD USMember

    found it in the keychanin

  • nabilnabil USMember
    edited June 2013

    What was the solution!? I'm having same problem; I can checkout from SVN but I cant commit. Seems that xamarin studio saves the credentials somewhere!?

    I deleted my svn key from keychain, but that didn't solve the problem and made it even worse now its giving me the error that It cant add the credentials to the key-chain when I try to commit.

    Version control operation failed: . Could not add internet password to keychain: The user name or passphrase you entered is not correct.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Did you delete the key from the keychain while Xamarin Studio was open or closed?

    Please file a bug with more details - version, OS version, etc.

  • RupertRawnsleyRupertRawnsley GBMember ✭✭✭

    I get the same error on a Mac with OS 10.8. Deleting the Keychain entry for works for the next operation regardless of whether Xamarin is running at the time or not. You get prompted for your credentials and the operation succeeds. However, the next time you try it just fails again until you delete the credentials. My uneducated guess is that Xamarin is mangling reading or writing of the credentials somehow.

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    I will take care of this, it is top on my priority list as of now.

  • BrianMainsBrianMains USMember

    I'm getting that connecting to TFS with GIT project; I entered the wrong password, and now it remembers it... maybe a restart will help...

  • BrettAnthonyBrettAnthony AUMember

    Had this error also on Mac. Deleting the keychain entry worked. Second time round it asked for user and pass and pushed the changes to git fine. Team Xamarin, simple bug fix, it should only store the credentials into the keychain AFTER a successful commit/push etc, not before. Keep up the great work!

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    @jstedfast, check the above answer.

  • DaveHDaveH USMember

    @mungureanu @jstedfast any update on the progress of this please?

  • ninlarninlar USMember, University

    I had the same issue on Windows. Instead of deleting the credential from Key Chain, you have to remove it from the Windows Credential Manager. Also, if you are using Team Foundation Service, make sure you setup alternate credentials, since you have to use them. Finally, make sure your alternate credential's username is different than that of your Live ID. This was a pain to figure out through trial and error.

  • MarkReynoldsMarkReynolds USMember ✭✭

    Is there any update on this item. I'm having the same problem on my mac. I can delete the keychain entry, do a push from Xamarin Studio, I'm promoted for my user id and password and the push works. The next push fails saying "Not Authorized" and I have to go back and delete the keychain entry again.

    --- versions

    Xamarin Studio
    Version 4.1.13 (build 17)
    Installation UUID: e579a4d0-f50b-4ba4-a7f6-229498f469d9
    Mono 3.2.4 ((no/294f999)
    GTK+ 2.24.20 theme: Raleigh
    GTK# (
    Package version: 302040000

    Operating System
    Mac OS X 10.9.0
    Darwin 13.0.0 Darwin Kernel Version 13.0.0
    Thu Sep 19 22:22:27 PDT 2013
    root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @MarkReynolds: Can you repro with version 4.2?

  • MarkReynoldsMarkReynolds USMember ✭✭

    I just tried with 4.2 and had the same issue.

    The project I'm working with is using GitHub with TFS and the username used for authentication is an internal domain name like [email protected] Not sure if that might be causing the problem but I did notice that the Repository Configuration dialog does not like you trying to enter @ with a domain name after it.

    Thanks for the help

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @MarkReynolds: I suspect it might be because the VCS addin stores repository settings as URLs, and the @ character has a special meaning in URLs. It may be that you could URL escape the @ in your username, i.e. use %40. If that doesn't work, please file a bug for @MariusUngureanu to look at - though I fear it'll be difficult to fix without access to a git server that uses @ in usernames.

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    I could set up a git server locally, but I need to find out how to configure it to be like that. Will take a look at it.

  • MarkReynoldsMarkReynolds USMember ✭✭

    @Michael; I'll give that a try when I'm back onsite on Monday.

    @Marius; thanks for the help with this.

  • MartynMartyn USMember
    edited November 2013

    Mhutch, I would like to point out that this problem persists when you're using the HTTPS version of GitHub, which, if I understand correctly, does not have an "@" in the username. Given that most (?) Git users use GitHub, and given that MAC OS X users don't have directly access to Subversion due to another Xamarin bug, our options for version control are quite limited.

    This is quite debilitating. The sooner we can get these issues addressed, the better.

    Thank you...

  • MartynMartyn USMember

    For clarification, here's the error message I'm getting:

    Version control operation failed: .[repo name].git: not authorized

    Notice the absence of an "@" in the URL. This should be easier to troubleshoot, hopefully?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @Martyn: pushing/pulling to/from works fine for me.

    Maybe you are not using the correct username/password? Do you have two-factor auth enabled on GitHub?

  • MartynMartyn USMember

    No, I do not have two-factored enabled. Do you recommend that?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    I would recommend you enable two factor auth on every service you use that supports it, since it substantially increases account security :)

    However, since you don't have it enabled, my guess was wrong - I was guessing that GitHub was denying access since XS couldn't provide the second factor.

    Something I did do that you may not have done was to generate an app-specific password in GitHub account settings, and use that in XS instead of using my GitHub account password. Maybe try that?

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    @Martyn, is there anything in the keychain regarding the git credentials through XS? If so, is the data correct?

  • MarkReynoldsMarkReynolds USMember ✭✭

    This afternoon I tried encoding @ with %40 with no change in behavior. I will file a bug; I have not found a way to disable saving credentials which would solve a lot of my problems. I can go to Keychain Access and delete the credentials each time and the push/pull works.

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    Hey guys! The bug has been fixed and will be added in future releases! Thanks for pressing me to try and fix it once again! :D

  • MarkReynoldsMarkReynolds USMember ✭✭

    Thanks for the fix; much appreciated.

  • MarkReynoldsMarkReynolds USMember ✭✭

    @Marius, is there an estimate on when a new release might be coming?

  • MarkReynoldsMarkReynolds USMember ✭✭

    I have confirmed that the problem I described in a comment on 11/12 still exists in Xamarin Studio 4.2.2. Was this suppose to have been resolved?


  • rezidualrezidual USMember

    bump....any ideas in which release the fix for this will be included? release date?

  • rezidualrezidual USMember

    @MariusUngureanu in which release of Xamarin Studio can we expect the fix? i'm still having this issue with release 4.2.2 (build 2).

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Probably 4.2.3.

  • GarethBrownGarethBrown GBMember ✭✭

    Michael, thanks for letting us know. It's really frustrating. Do you know when you're going to be releasing 4.2.3?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @GarethBrown.9791 it's currently in the beta update channel. It'll be released to stable once it's been in the beta channel for a while without any serious regressions reported against it.

  • StephenGrayStephenGray USUniversity ✭✭

    Same thing just happened to me but deleting the password from the key chain and restarting XS worked.

    XS Version 4.2.3 (build 60)

  • Hi, I still seem to have this problem. If the project on github is not empty, the publish fails with a "non authorized" error.
    This happens on Windows 8 and XS 5.4 build 240.
    It has to also be noted that XS crashes if the solution is under github version control and the regional settings of the machine have a different date format than mm/dd/yyyy
    I had filed a bug but it was closed with the reason "This works on the libgit2sharp switch. Marking as resolved for that branch."

  • MalavShahMalavShah USMember
    edited July 2015


    I am having trouble pushing my code to github repo. I had entered the wrong password and now I am not getting the prompt to re-enter the password.

    Can anyone please help me resolve this issue? Xamarin Studio version: 5.9.4 (build 5)
    Operating System: Windows 8.1


  • MalavShahMalavShah USMember

    Sorry. I should have done some more research before posting. I was able to resolve the issue by removing credential saved under Windows credential manager. Thanks.

  • RickKozakRickKozak CAMember

    Ran into the same problem today with Xamarin Studio on Windows 10 when trying to access a GIT repository on Visual Studio Online by typing my normal password into the login prompt while having two factor authentication turned on.

    Solved by creating a Personal Access Token (found in 'My Profile' -> 'Security' on VSOnline) and then editing password of the credential in the list of 'Generic Credentials' shown by the Windows Credential Manager control panel item.

  • PeterConreyPeterConrey USMember, University

    I am having the same problem on Mac OS X (10.10.5). Xamarin Studio 5.9.7. Any idea when this will really be fixed?

  • MortenKoMortenKo NOMember

    I have the same problem as PeterConrey, XS on Mac, entered wrong password once for when adding a Git repo and now I cannot change the password and it never promps me to enter it again so stuck. Looked at the keychain but didn't see anything related there.

Sign In or Register to comment.