Issue with creating IPA file.

SreeeeSreeee ✭✭✭✭✭INMember ✭✭✭✭✭

Hi,

I follow the below steps for creating an IPA file.

  1. Selected the iOS project as the startup project.
  2. Select the Release | Device configuration in Visual Studio for Mac.
  3. From the Build menu, select Archive for Publishing.

At this 3rd stage, I am getting a pop-up box and telling "Configuration doesn't target device". I am adding the screenshot of the popup.

At the Debug mode device is there but when I changed it to the release mode it is showing the device as Default.
I refer the following blog; https://docs.microsoft.com/en-us/xamarin/ios/deploy-test/app-distribution/ipa-support?tabs=vsmac

Thanks in advance :)

Tagged:

Best Answers

  • SreeeeSreeee ✭✭✭✭✭ IN ✭✭✭✭✭
    Accepted Answer

    @seanyda Solved this issue by following way.

    Options from master project --> configurations -->check the build option of ios project. Then the release mode showing the generic device option. Screenshot adding below:

  • seanydaseanyda ✭✭✭✭✭ GB ✭✭✭✭✭
    Accepted Answer

    @Sreeee said:
    @seanyda When I try to select the Archieve option from the Build menu getting the following error.

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets(3,3): Error: No valid iOS code signing keys found in keychain. You need to request a codesigning certificate from https://developer.apple.com. (Business_App.iOS)

    Do you have any comment about this?

    Sure. You need to create a certificate and provisional profile at developer.apple.com and sign the IPA with it. You can select the provisional profile from the "Bundle Signing" section when you double tap the Business_App.IOS project.

Answers

  • seanydaseanyda ✭✭✭✭✭ GBMember ✭✭✭✭✭

    What does that "information" tab show when you hover over it next to Business_App.iOS? That will probably be the cause of the issue.

    I see this:

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭

    Hi @seanyda Only showing default option at the Release mode, no other options are available.

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭

    @seanyda On the Debug mode, all the available devices are showing. But no devices are showing in Release mode.

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭
    Accepted Answer

    @seanyda Solved this issue by following way.

    Options from master project --> configurations -->check the build option of ios project. Then the release mode showing the generic device option. Screenshot adding below:

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭

    @seanyda When I try to select the Archieve option from the Build menu getting the following error.

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets(3,3): Error: No valid iOS code signing keys found in keychain. You need to request a codesigning certificate from https://developer.apple.com. (Business_App.iOS)

    Do you have any comment about this?

  • seanydaseanyda ✭✭✭✭✭ GBMember ✭✭✭✭✭
    Accepted Answer

    @Sreeee said:
    @seanyda When I try to select the Archieve option from the Build menu getting the following error.

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets(3,3): Error: No valid iOS code signing keys found in keychain. You need to request a codesigning certificate from https://developer.apple.com. (Business_App.iOS)

    Do you have any comment about this?

    Sure. You need to create a certificate and provisional profile at developer.apple.com and sign the IPA with it. You can select the provisional profile from the "Bundle Signing" section when you double tap the Business_App.IOS project.

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭

    @seanyda: Thanks for the information, I am not going to upload the app now, when I upload I will do this. If any doubt I will ping you at that time. :) :) :)

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭
    edited July 2018

    @Charwaka @AlessandroCaliaro @NMackay @seanyda

    Hi now I am uploading the app to app store.

    Logged in to the developer.apple.com and create a certificate like below:

    But still getting the same error:

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets(3,3): Error: No valid iOS code signing keys found in keychain. You need to request a codesigning certificate from https://developer.apple.com. (Business_App.iOS)

    Thanks in advance :)

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭

    @seanyda I am referring the following blog.
    https://support.magplus.com/hc/en-us/articles/203808748-iOS-Creating-a-Distribution-Certificate-and-p12-File

    Can you tell which file need to browse to complete the following step?

  • SreeeeSreeee ✭✭✭✭✭ INMember ✭✭✭✭✭
    edited July 2018

    @seanyda

    When I try to create the distribution certificate found that there is a CSR file generation, I follow the below steps for creating CSR file.
    application folder --> Utilities folder--> keychain access

    Within the keychain access, I am not seeing any drop-down window. As per the blog, there is a drop-down window and which have some options.

    Thanks in advance :)

  • seanydaseanyda ✭✭✭✭✭ GBMember ✭✭✭✭✭

    @Sreeee said:
    @seanyda

    When I try to create the distribution certificate found that there is a CSR file generation, I follow the below steps for creating CSR file.
    application folder --> Utilities --> keychain access

    Then what?

    You need to create the CSR in key chain access and sign the certificate with it on developer.apple.com. You can't create a valid certificate without completing that step correctly.

Sign In or Register to comment.