iOS Binding Project builds but can't reference

I have been working on creating a binding project for an iOS SDK for the last week or so. I have gone through the steps in the Xamarin Developer guides walkthrough, I created the .a library on the Mac and ran the sharpie tool to create ApiDefinitions and Structs. I then created the binding project and put the library and code from the ApiDefinitions and Structs into the relevant files. I got a lot of error messages which I have worked through and solved so the project now builds successfully.

My issue is that I can't seem to do anything with the project now. When I look at it in Visual Studio Object Browser no classes appear below it. I can reference it in an iOS project but I can't seem to use it within a class.

I was wondering if anyone had any ideas on what could be wrong. Any advice is appreciated.



  • System.AshSystem.Ash AUMember ✭✭


  • CarlosAndersonCarlosAnderson USMember ✭✭
    edited February 16

    I'm having the same problem in Visual Studio 2017. Even though the iOS Binding project is being referenced by my iOS project, IntelliSense doesn't recognize any classes in the iOS Binding project. However, the iOS project builds successfully.

    Has anyone found a solution to this?

  • CarlosAndersonCarlosAnderson USMember ✭✭

    For some reason, the iOS Binding project shouldn't be in the same solution as the iOS project. Move the iOS Binding project to another solution and build it. From the iOS project, reference the generated assembly DLL directly. It must be a Visual Studio bug. I found the answer here.

Sign In or Register to comment.