error: package com.google.android.gms.gcm

When trying to build our Xamarin Android solution we are getting this error error: package com.google.android.gms.gcm during compilation. The GCM package is installed (and updated to latest). The .cs file allows us to inherit from the GcmListenerService, but fails during the build.

We've tried removing and adding the packag and it's dependencies one by one and end up with the same result.

We're using the current stable build of Xamarin/Android. We also tried switching to the beta branch. Nothing helps.

Tagged:

Answers

  • @ MichaelLeatherbury,

    Hi,

    Currently GCM was outdated, Try using FireBase for push notifications.

    So on of the possible reasons for this error could be that you may have recently updated your other Xamarin packages and Dependencies GCM would cause trouble as new updates only support FireBase for push notifications.

    Thank you.

  • MichaelLeatherburyMichaelLeatherbury USMember ✭✭

    The weird issue we are having is that some of us are able to build with the GCM package. It's only when the repo is pulled down for the first time does it have this issue. It's also causing our CI/CD to fail.

Sign In or Register to comment.