IOS hello world project couldn't be debugged on mac pro

KepingWuKepingWu USMember, University

Trying to run my first ios app on mac pro, failed.

Visual Studio 2012 update 3, latest xamarin installed on both windows pc and mac pro. xamarin.ios latest package installed.

Getting the following error when building and debugging on iPhoneSimulator:

ERR: There was an error launching the application: SpringBoard failed to launch application with error: 4

Any response will be highly appreciated!

Posts

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @KepingWU try to run your app project in Xamarin.Studio on the Mac. Look in the "Application output" window for any error hint on what might cause the problem.

    Try placing breakpoints in your code starting from the AppDelegate.cs file to see how far you get.

    If the app won't start and you are not getting to any meaningful place in code via breakpoints then the problem might be some file in your project that has the wrong build type or file type. Also it is important that you fix all build warnings.

    If you need further help, then please provide some more information, screenshots, code etc.

  • KepingWuKepingWu USMember, University

    It was caused by the xamarin.ios visual studio plugin, The application name, identity, version number need to be filled in two places: 1. Property of the project; 2. Info.plist.

    Once I put information in two places, it works.

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @KepingWu I am glad you got it working :-)

Sign In or Register to comment.