Why can't I build using the latest nightly builds?

I'm hoping this is the right spot for this. I have a quick question and was hoping I may get some direction?

We are trying to add a NuGet package reference to the nightly branches of Xamarin.Forms (mainly so we can try some of the WPF pieces contained in there); however, as soon as we add that and try to build, we are getting a:

1>C:\Users\user\.nuget\packages\xamarin.forms\3.1.0.283669-nightly\build\netstandard1.0\Xamarin.Forms.targets(35,3): error MSB4062: The "Xamarin.Forms.Build.Tasks.GetTasksAbi" task could not be loaded from the assembly C:\Users\user\.nuget\packages\xamarin.forms\3.1.0.283669-nightly\build\netstandard1.0\Xamarin.Forms.Build.Tasks.dll. Could not load file or assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.

Any ideas? It's been really bugging me trying to figure this one out.

Answers

  • MarijkeMarijke Member ✭✭

    I got the same error on exercise 2 from XAM150.

  • ellix4uellix4u USMember ✭✭

    Delete obj folder in all the platform. Restart visual studio, clean and build.

  • PhilippeLeybaertPhilippeLeybaert BEMember ✭✭

    Upgraded a PCL project to today's released Xamarin Forms 3.0 and I get the exact same error. It's no longer possible to build.

    Could not load file or assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified. Confirm that the declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask

    Things I tried:

    • Uninstalling Xamarin Forms completely from the project
    • Exited Visual Studio
    • Removing all bin and obj folder
    • Removing the packages folder from the solution folder
    • Reinstalling Xamarin Forms 3.0 from scratch

    Nothing works.

Sign In or Register to comment.